Save and Continue Problems

  • Profile Image
    tigovernance
    Asked on March 16, 2016 at 05:41 AM

    Dear JotForm Team,

    I have been in touch with your support staff yesterday regarding continuous problems we are experiencing with the save&resume functions.

    Indeed, we have set up two forms in order to collect the email address of the person working on the form - the 'First Form' which is accessible here: https://eu.jotform.com//?formID=51102469541348 as well as the actual form, which contains an extensive survey - the 'Main Form', which is accessible here: https://form.jotformeu.com/51101821313336

     

    The Problem we are experiencing now is that if the First Form is used in order to provide the original email address of the contact person and the generated link then is used to access the Main Form that information that is entered into the Main Form is no longer retrievable (via the original link that was generated through the First form) in case the window is closed by accident or the computer crashes, even though at least one 'Next' button has been pressed.

    This is very troublesome, as we are working with a very long survey and our members cannot be expected to enter all information in one sitting.

    of course it is quite possible that there has been a mistake on our part when we set up the two forms, but as the matter is quite urgent, it would be wonderful if you could have a look into both forms so we can see where the issue is originating from and to hopefully find a quick solution.

     

    Thank you very much in advance -

    Felicia

  • Profile Image
    mert
    Answered on March 16, 2016 at 06:22 AM

    Hi Felicia,

    I see that you have already set up "Save and Continue Later" link to your form's (Contact Details Request for NC Accreditation Process) "Thank You" page and I cloned those forms and tested the link on the "Thank You" page.

    The issue is this you need to be sure that the link has the related email address instead of having variable from email field ({email16}) when you are using the "Save and Continue Later" link. For example, my email for the related submission is "mert@jotform.com"; but my link is still "https://form.jotform.com/60752347217960?session={email16}". It will monitor the form without previous submissions.

    Please, see it from the below:

     

     

    If I set the email address correctly for that session, it will provide the answer from previous session.

     

    So, you and your users need to be sure about this one. Normally, this is done automatically on the "Thank You" page as you have already noticed; but if it comes to you like this, this could be the reason for this problem.

     

    For further assistance, please do let us know.

    Regards.