What is JotForm?
JotForm is a free online form builder which helps you create online forms without writing a single line of code. No sign-up required.

At JotForm, we want to make sure that you’re getting the online form builder help that you need. Our friendly customer support team is available 24/7.

We believe that if one user has a question, there could be more users who may have the same question. This is why many of our support forum threads are public and available to be searched and viewed. If you’d like help immediately, feel free to search for a similar question, or submit your question or concern.


  • Profile Image

    "Please wait" hangs on submit for only one user

    Asked by kenb0t on March 16, 2016 at 11:35 AM

    One user has a problem submitting a specific form, but no one else is experiencing a problem with this form. Even a different Windows user logged on the same PC does not have a problem. The user who is experiencing the issue has no problem submitting other forms. I cleared the cache and restarted the browser, both Chrome and IE 11. Windows 7 environment

    Page URL:
    http://form.jotformpro.com/form/52095809036963

    please wait on submit problem cache pc different
  • Profile Image
    JotForm Support

    Answered by BJoanna on March 16, 2016 at 12:30 PM

    I have tested your form and I was not able to replicate mentioned issue. When I submitted your form I got redirected to Thank You page. I have tested your form on Windows 7 environment in Google Chrome.

    Is your form embedded to website? If so please provide us URL of your website, so that we can test your form there.

    Considering that this is happening to only one user, you can ask that user to try to submit your form again. Also ask them to update their browser to the latest version. They can also try to submit your form in incognito mode

    Hope this will help. Let us know if you need further assistance.

  • Profile Image

    Answered by kenb0t on March 16, 2016 at 01:01 PM

    It is not embedded in a website. The user has attempted multiple times, and the browser is updated. I tried incognito mode, but the problem persisted even then

  • Profile Image
    JotForm Support

    Answered by BJoanna on March 16, 2016 at 01:42 PM

    I have cloned your form and tested my cloned form several times and my form was submitted successfully each time. 

    Can you please ask your user to try to submit your form on some other device. It seems that this issue is related to that specific device. 

    You can also try to clear your form cache

    Let us know if you need further assistance.

  • Profile Image

    Answered by kenb0t on March 18, 2016 at 10:36 AM

    The problem appeared for two additional users, for a total of three.

     

    For two of them, I was able to solve the problem by removing their Windows profile from their machine and forcing it to reload from the network.

     

    But for one user, that did not solve the problem

     

    I was able to find a workaround by, after the browser loads the form, removing one of the submit event listeners from the form. If she does that before she fills out and submits the form, it doesn't hang and she gets the Thank You screen right away. But she has to do this every time she wants to submit a form.

  • Profile Image

    Answered by Carina on March 18, 2016 at 11:36 AM

    I cloned your form and edited some parts. Please try cloning the demo form and see if the problem persists:
    https://form.jotform.com/60774887078978

    We'll wait for more details to proceed. 

  • Profile Image

    Answered by kenb0t on March 18, 2016 at 12:38 PM

    It worked! What needed to be changed? Can the change be made on the original form so all the submissions stay in the same place?

  • Profile Image

    Answered by kenb0t on March 18, 2016 at 12:46 PM
    That worked! What needed to be changed? how can we have all the submissions going to the original form?
    ________________________________
    ...
  • Profile Image
    JotForm Support

    Answered by BJoanna on March 18, 2016 at 01:10 PM

    I have compared your form and cloned form my colleague provided you and only difference that I saw is that my Carina deleted MouseStats Form Analytics widget from her form.

    You can delete MouseStats Form Analytics by selecting that field inside of you Form Builder and clicking on delete option.

    Feel free to contact us if you have any other questions. 

  • Profile Image

    Answered by kenb0t on March 18, 2016 at 01:20 PM

    Thank you. That worked swimmingly.

  • Profile Image
    JotForm Support

    Answered by BJoanna on March 18, 2016 at 01:24 PM

    On behalf of my colleague, you are welcome.

    Feel free to contact us if you have any other questions. 

  • Profile Image

    Answered by kenb0t on March 29, 2016 at 10:42 AM

    Bad news: The problem has returned. Different users this time, and forcing the Windows profile to reload does not solve the problem; when certain users click submit, it just says please wait forever.

    Removing an event listener before filling out and submitting the form works every time. If they do this, after clicking submit, the form goes through immediately.

  • Profile Image
    JotForm Support

    Answered by BJoanna on March 29, 2016 at 12:13 PM

    I have tested your form and again I was not able to replicate mentioned issue. I was able to successfully submit your form. 

    I have also coned your form and I saw that you have only Timer widget. Last time MouseStats Form Analytics widget was causing issue on your form. 

    However when I inspected elements of your form I found 3 console errors, related to theme of your form. You can try to remove your Theme to see if that will resolve your issue. To do that inside of your form builder click on Themes option and then on My Themes tab remove theme. 

    Here is my cloned form on which I removed theme: 

    https://form.jotform.com/60885291105961 

    Also I did not understood this part of your post: "Removing an event listener before filling out and submitting the form works every time." Can you please clarify this? 

    Hope this will help. Let us know if you need further assistance.

  • Profile Image

    Answered by kenb0t on March 31, 2016 at 12:09 PM

    Although the cloned form worked for the user, I removed the theme and people are still having this issue. The only thing that works is removing the event listener. What I mean by that is Chrome allows you to dynamically edit the page in its developer tools. In Chrome, navigate to the form, press F12, click on the form level, go to the event listeners tab; in the submit section, there are two event listeners. If you mouse-over them, a remove button appears. If users remove this event listener before they fill out the form, it always works, but its a big pain to do that every time.

  • Profile Image
    JotForm Support Manager

    Answered by Jeanette on March 31, 2016 at 03:41 PM

    I would suggest the user to reset the browser, if that doesn't work try installing Firefox as it seems like Chrome and IE are corrupted in that machine.