What is JotForm?
JotForm is a free online form builder which helps you create online forms without writing a single line of code. No sign-up required.

At JotForm, we want to make sure that you’re getting the online form builder help that you need. Our friendly customer support team is available 24/7.

We believe that if one user has a question, there could be more users who may have the same question. This is why many of our support forum threads are public and available to be searched and viewed. If you’d like help immediately, feel free to search for a similar question, or submit your question or concern.


  • Profile Image

    I again tried to make edits on the clone form that are not taking?

    Asked by BettyArnold on March 21, 2016 at 02:08 PM

    I deleted all the previous clones made last week and used the procedure I received last week. The same is happening, I go into cloned document, got to edit mode, make changes, hit save, and then preview and edits are not there?

    Page URL:
    https://form.jotform.com/60805745965971

    Taking Make make edits preview edit mode same document
  • Profile Image

    Answered by victor on March 21, 2016 at 02:26 PM

    Sorry for the inconvenience. I have just cloned your form and added a header "THIS IS A TEST". After saving I was able to view the field added in the PREVIEW window. Can you please try clearing the cache and cookies from your browser. If you are still having problems, please indicate the browser you are using, so we may test it again.

     

  • Profile Image

    Answered by BettyArnold on March 21, 2016 at 02:41 PM

    I cleared my cache and cookies and it still didn't take my edits. My browser is: 

     Chrome 49 on Windows 10

  • Profile Image
    JotForm Support

    Answered by Charlie on March 21, 2016 at 03:02 PM

    May we know what are the specific changes that are not showing in your form? 

    Please do make sure that you are not opening multiple form builders, editing multiple forms. And that you are logged in successfully, you can refresh the page to see if your session ended or timed out.

    I cloned your form and made a test and was not able to replicate the problem. Here's a screencast where I edited my cloned form and preview it.

     

    Perhaps you might be viewing the original form and not the cloned one where you made the changes? Could you also please try using a different browser and see if the same problem persists there? So far, we are unable to replicate the problem and we haven't receive similar reports (yet). I also tested it on Mac OS X El Capitan using Chrome version 49, but was not able to replicate it there.

    Apologies for the inconvenience.