Form and Report Picker not loading forms

  • Profile Image
    Karl Markiewicz 
    Asked on April 01, 2016 at 01:17 AM

    Hello,

     

    I am developing a website that integrates Jotform, in specific it utilises the 'Form Picker'. Today when I started working on the website I noticed when I opened the Form Picker I get the following error message displayed in the form picker window:

    "SOMETHING WENT WRONG WHEN FETCHING FORMS, PLEASE TRY AGAIN."

    I then checked the developer console (F12) and it threw the following error:

    XMLHttpRequest cannot load http://api.jotform.com/user/forms?apiKey=<my api key>&filter={%22status%22:%22ENABLED%22}&limit=100&orderby=updated_at,DESC. The 'Access-Control-Allow-Origin' header contains multiple values '*, *', but only one is allowed. Origin 'http://developers.jotform.com' is therefore not allowed access.

    I suspect this is definitely a bug on JotForm's end as I used the FormPicker Demo on the JotForm site and it threw the same errors. Also, the form picker and everything else was working just fine yesterday.

    Help ASAP, would be great, as this is stopping my website from functioning. Thanks!

    Karl.

     

  • Profile Image
    EltonCris
    Answered on April 01, 2016 at 06:17 AM

    Hello Karl,

    That might have something to do with the downtime recently. I just checked the Form Picker demo and it is working now. Would you mind checking it again?

  • Profile Image
    GPTQ
    Answered on April 03, 2016 at 08:25 PM

    Yep, it is working now.

    Thank you!