Jotform takes time to load on my webpage

  • Profile Image
    mishra_rohan
    Asked on April 02, 2016 at 02:51 AM

    Hi Team,

     

    I love Jotform for multiple reasons but was not happy with the overall loading time of the form.

    Can you please help?

    Regards,

    Rohan

  • Profile Image
    Chriistian
    Answered on April 02, 2016 at 05:36 AM

    I checked your form - http://www.jotform.me/form/60692581273460 and I was able to load the form properly in seconds. Are you still encountering the issue? Can you give us more details regarding the issue so we can further check?

     

    We will wait for your response.
    Regards.

  • Profile Image
    Rohan 
    Answered on April 02, 2016 at 05:46 AM

    Thanks for the prompt response Christian. When I am hitting the form directly using the above URL it comes up immediately but when I embedded the source code onto my website (http://www.rohanmishraphotography.com/contact-us), it takes around 5 seconds to load the form.

    I even checked a jotform embedded in the page hosted by the same provider (http://www.evanchungphoto.com/pricing-request) and this comes up lot quicker.

     

    Is there a way you can help me with this?

    Thanks,

    Rohan

  • Profile Image
    liyam
    Answered on April 02, 2016 at 06:51 AM

    Hello Rohan,

     

    I have checked your page and it loaded fine, and without significant delay.

    What I noticed on your page was it was loading at the same time with the top navigation bar. So there might be something on the navigation bar which causes the slow loading of the page.

    Also, I noticed that you are using the full source code of your form already which should no longer be much dependent on the sources being collected from JotForm website. Although you can still just download the javascript and CSS files, and host it on your domain if you think that the delay is being caused by these.

    Feel free to let us know if you have further questions or concerns.

    Thanks.

  • Profile Image
    Rohan
    Answered on April 02, 2016 at 09:07 AM

    Thanks for the support Liyam. I might have to check my page settings.

    Regards,

    Rohan