Form Tabs widget with "Allow navigation without validation" causes submit button to work as next button.

  • Profile Image
    MilesDalton
    Asked on April 04, 2016 at 08:20 PM

    Hi there,

    whenever users are clicking the submit button on any of the pages, the submit feature does not work any more. It was working a few days ago.

    Now, the form just skips to the last page and nothing is saved.

    I am just in the process of final testing before I start paying - I will be using this as the application form for a local business awards. But if people can't submit that is going to be big trouble for me.

    kind regards

     

    Miles

  • Profile Image
    ashwin_d
    Answered on April 04, 2016 at 10:28 PM

    Hello Miles,

    I'm sorry for the trouble caused to you.

    I did test your form and I am able to replicate the issue you are having. The submit button does not work in your form and it only behaves like a next button which takes you to next page. 

    There seems to be some glitch with "Form Tabs" widget where if you set the "Allow navigation without validation" option to "Yes", the submit button does not work anymore. Please check the screenshot below:

     

    I am reporting it to our back end team. We will get back to you as soon as we have any update from them. For now, there are two options to solve this problem:

    #1. Disable "Allow navigation without validation" property of "Form Tabs" widget and that should solve this problem.

    #2. Another option is to add a "Submit button at the last page of your form.

    Thank you!

     

  • Profile Image
    TitusN
    Answered on July 18, 2016 at 02:40 AM

    We've made a few updates to the widget to address the issue. 

    Please give it a second try - see if the submit button works as expected while using the form tabs widget. 

  • Profile Image
    MilesDalton
    Answered on July 18, 2016 at 04:42 PM

    Thanks for that, much appreciated. However the workaround you had suggested did work. I have used and finished with the form now.

    Another suggestion for the submit button - I note that when people have attached a number of uploads to their form, it can take a while to upload but there is nothing to indicate that it is uploading. Possibly adding something to make the submit button say 'processing' while it is doing that would be very helpful.

     

    Cheers

  • Profile Image
    BDAVID
    Answered on July 18, 2016 at 06:03 PM

    Your suggestion will be addressed on the following thread: https://www.jotform.com/answers/885407