"Notification" email body keeps deleting the contents on it

  • Profile Image
    adamshomes
    Asked on April 06, 2016 at 08:42 AM

    This is probably the 30th time i have updated our form notifications. Please look at the formID=12344536260

    This is the 4th notification that i have done for this form alone and it keeps happening. 

    notification 2 all the sudden has "undefined" as the body. I left it so you could see.

    I just created Notification 3. 

    Your support forums say just redo the form and it should be fine. I dont want to keep doing this. i want my forms working.

    PLEASE FIX THIS AS SOON AS POSSIBLE AND UPDATE ME!!!!!!

  • Profile Image
    mert
    Answered on April 06, 2016 at 09:32 AM

    Hi there,

    On your "Notification 2", I replicated the same issue; but we can easily beat this issue by copying the table design's source code from "Notification 3" to "Notification 2".

    Firstly, please see the HTML source code from the below:

    <html><head></head><body class="Created on Form Builder"><table bgcolor="#f7f9fc" border="0" cellpadding="0" cellspacing="0" width="100%">

    <tbody>

    <tr>

    <td height="30">&nbsp;</td>

    </tr>

    <tr>

    <td align="center">

    <table bgcolor="#eeeeee" border="0" cellpadding="0" cellspacing="0" width="500">

    <tbody>

    <tr>

    <td height="36" bgcolor="#EEEEEE" width="4">&nbsp;</td>

    <td bgcolor="#EEEEEE" width="30"><img style="display: block;" src="https://cdn.jotfor.ms/assets/img/builder/email_logo_small.png" alt=""></td>

    <td style="font-size: 16px; vertical-align: middle; color: #f9922b; padding-top: 2px; line-height: 20px;" align="left" bgcolor="#EEEEEE"><strong>Florida - Orlando</strong></td>

    </tr>

    </tbody>

    </table>

    <table bgcolor="#eeeeee" border="0" cellpadding="0" cellspacing="0" width="500">

    <tbody>

    <tr>

    <td bgcolor="#EEEEEE" width="4">&nbsp;</td>

    <td align="center" bgcolor="#FFFFFF">

    <table id="emailFieldsTable" class="mceEditable" border="0" cellpadding="5" cellspacing="0" width="100%"><tbody><tr>

    <td style="padding:5px !important;" bgcolor="white" valign="top" width="170">Name</td><td style="padding:5px !important;" bgcolor="white">{name}</td></tr>

    <tr>

    <td style="padding:5px !important;" bgcolor="#f9f9f9" valign="top" width="170">Phone</td><td style="padding:5px !important;" bgcolor="#f9f9f9">{phone}</td></tr>

    <tr>

    <td style="padding:5px !important;" bgcolor="white" valign="top" width="170">E-mail</td><td style="padding:5px !important;" bgcolor="white">{email4}</td></tr>

    <tr>

    <td style="padding:5px !important;" bgcolor="#f9f9f9" valign="top" width="170">Click to edit</td><td style="padding:5px !important;" bgcolor="#f9f9f9">{clickTo5}</td></tr>

    <tr>

    <td style="padding:5px !important;" bgcolor="white" valign="top" width="170">Community Name</td><td style="padding:5px !important;" bgcolor="white">{communityName}</td></tr>

    </tbody></table>

    </td>

    <td width="4">&nbsp;</td>

    </tr>

    <tr>

    <td style="font-size: 4px;" height="4">&nbsp;</td>

    <td style="font-size: 4px;">&nbsp;</td>

    <td style="font-size: 4px;">&nbsp;</td>

    </tr>

    </tbody>

    </table>

    </td>

    </tr>

    <tr>

    <td height="30">&nbsp;</td>

    </tr>

    </tbody>

    </table>

    <p><br><br></p>

    <p>&nbsp;</p>

    <pre>&nbsp;</pre></body></html>

     

    By using this one we can generate the same template from the "Notification 3". Please, see the steps:

     

    Then please change the "{communityName8}" to the "{communityName}" on the title of the email.

     

    This method is working on my side, so please try it and do let us know the results.

    Regards.

  • Profile Image
    adamshomes
    Answered on April 07, 2016 at 11:47 AM

    Yes, i understand how to do that, I have been using Jotform for years and have hundreds of forms on another account. but i want to know WHY it keeps happening to my forms. Another one this morning. WHY?

  • Profile Image
    EltonCris
    Answered on April 07, 2016 at 01:04 PM

    First off, our sincerest apologies for the inconveniences this has caused.

    That usually occurs when there's an issue fetching the notification content from the server specially when it contains messed up codes after it was edited. I don't think this affects your entire form.  I believe, this is notification specific. If your form was saved with this changes, I'm afraid it can't be recovered anymore. The easiest way to resolve this is to recreate that email notification. 

    If you continue to encounter this problem after recreating the email notification, let us know so we can have our developers check this for you. 

    Thank you!

  • Profile Image
    adamshomes
    Answered on April 07, 2016 at 02:05 PM

    Hello Elton, Thanks for your quick response. This has happened to multiple forms Multiple times on each form. That is cause enough for me to ask you to have your developers look into this. 

    Some forms i have redone the email notification 4 TIMES. I can understand once as an issue, but i have done this more than 30 times now. and it is happening 3-4 times a day now. I have had 2 in the last 3 hours.

    I just had another one on another form. It is like your system is just deleting all the form content in the notification email over and over.

    Please get this looked at ASAP.

     

  • Profile Image
    david
    Answered on April 07, 2016 at 02:38 PM

    I will forward this to our developers to have a closer look.  We will let you know via this thread as soon as we have any further information regarding your request.

  • Profile Image
    adamshomes
    Answered on April 13, 2016 at 09:25 AM

    Any Update on this?

  • Profile Image
    mert
    Answered on April 13, 2016 at 10:43 AM

    Unfortunately, the current status of the ticket is still open. When there is an update about this issue, you will be informed through email.

     

    Thank you for your patience.