My form is integrated with Infusionsoft and it is showing invalid refresh token after submission

  • Profile Image
    Asked on April 18, 2016 at 09:27 AM
    I am having exactly the same problem.  Again, Infusionsoft integration is involved.  If I remove it, the form runs fine, but as soon as I integrate it with Infusionsoft, I get the "Oops, Refresh Token Invalid" message.  So I will be very interested in your answer to Tidybooks.
  • Profile Image
    Answered on April 18, 2016 at 10:16 AM

    Sorry for the inconvenience. Can you please indicate if you tried removing the integration, clearing your cookies and cache. Can you also try creating a new API for InfusionSoft.

    If this does not help, please let us know.

  • Profile Image
    Answered on April 18, 2016 at 12:05 PM

    I tried removing the integration, cleared all history including cookies and cache.  But I got the same error message

     I do not understand the suggestion of generating a new API.  I know how to create an API and encryption key but I do not know what to do with them.

  • Profile Image
    Answered on April 18, 2016 at 02:11 PM

    Thank you for the update. As my colleague indicated in the previous thread you can generate a new API

    The issue seems to be caused because of the "Infusionsoft" integration you have in your form. I would suggest you to remove the Infusionsoft integration and add it again. You may also like to generate a new API key. The following guide should help you; 

    I was also able to integrate InfussionSoft properly in one of my forms.

    My colleague has already opened a ticket regarding the issue. Even though I was not able to replicate the problem, I will also create a new ticket so our team can analyze and see what may be causing the issue.

    Can you please indicate if this occurs in a particular form or every form you have has the same issue.

  • Profile Image
    Answered on April 19, 2016 at 05:59 AM


    I have tried removing the integration, deleting history, cookies etc and re-instating the integration.  I have tried it in 3 different forms, but always the same problem.

    If you click on the link below you can see how I do the integration, send an email with the link an test it, resulting in the usual error message.

    I can easily generate a new Encryption key, but as I said in my last email I do not know what to do with it. It is my understanding that the API key is used by applications that want to communicate with Infusionsoft, and not something that is done within Infusionsoft itself, other than generating the actual key.  So do I send it to you?

  • Profile Image
    Answered on April 19, 2016 at 07:25 AM

    Hello fergalkeane,

    Thank you for sharing additional details and screencast. My colleague have already reported this issue to our backend team. Upon checking the ticket status, I found that it is marked as important and one of my developer is already looking into this issue. We will get back to you as soon as we have any update from them.

    Thank you!

  • Profile Image
    Answered on June 02, 2016 at 11:22 PM


    We found the cause of this problem and have released a patch today. The issue should no longer persist.

    Please feel free to contact us again should you have questions or other concerns.

    Kind regards,