What is JotForm?
JotForm is a free online form builder which helps you create online forms without writing a single line of code. No sign-up required.

At JotForm, we want to make sure that you’re getting the online form builder help that you need. Our friendly customer support team is available 24/7.

We believe that if one user has a question, there could be more users who may have the same question. This is why many of our support forum threads are public and available to be searched and viewed. If you’d like help immediately, feel free to search for a similar question, or submit your question or concern.


  • Profile Image

    Wordpress loading white beam instead of form

    Asked by kasperp on March 06, 2012 at 08:09 AM

    Hello Jotform

    Thanks for a great WYSIWYG tool - I implemented it on my site which is based on wordpress.

    My problem is that sometimes when i load the page and the form is supposed to show; 1. sometimes it takes quite a while, several seconds which might lead people to think theres nothing there and leave and 2. sometimes its just a white beam and I have to hit refresh several times.

     

    Whats going on here and how do i fix it?

     

    Best

     

    Kasper

    Page URL:
    www.dev.thirst.dk/php-tilmelding

    Screenshot
  • Profile Image

    Answered by SeanDavis on March 06, 2012 at 08:28 AM

    Hi Kasper,

    I tried your form link above and it showed correctly and fast, the first time..

    Next i tried in a few seconds and the form did not load.. Could see actual code above the menu..

    Are you facing the same issue?

    Sean

  • Profile Image

    Answered by SeanDavis on March 06, 2012 at 08:29 AM

    Works fine now, in Chrome and IE.. 

    Cannot see the form on Firefox though..

    Sean

  • Profile Image

    Answered by kasperp on March 06, 2012 at 08:33 AM

    Hey Sean

    Thanks for testing. The issues are not constant, but random. I just tried it and had trouble getting anything to show at all. Especially if you're at the page and then try refreshing.

     

    It is difficult to narrow down due to being different errors seemingly at random..

     

    I'm using Chrome on a Mac experiencing this - and I can't even get the form to show using Safari.

  • Profile Image

    Answered by edz_kgs on March 06, 2012 at 08:34 AM

    Hi Sean/Kasperp,

    Could be an issue with your browser cache (clear cache and cookies) or remove broken firefox plugins. Also make sure you have a newer version of Firefox.

    Edz

     

  • Profile Image
    JotForm Support

    Answered by idarktech on March 06, 2012 at 08:38 AM

    Kasper,

    Can you please try to re-embed your form using iFrame code and see if that makes any differences? Thanks.

  • Profile Image

    Answered by pinoytech on March 06, 2012 at 08:40 AM

    Delete your browser cache and cookies first before re-embeding your form in to your web page.

    Thank you!

  • Profile Image

    Answered by kasperp on March 06, 2012 at 08:45 AM

    Thanks to everyone for all the quick replies. Tried the clearing cookies and cache and re-embeded with iFrame code - and with as much testing as such short time allows it does seem more stable.

    How is it looking on your end?

     

    Thanks!

     

    Edit: even shows in Safari now - great!

  • Profile Image

    Answered by edz_kgs on March 06, 2012 at 08:51 AM

    Looks PERFECT on my Firefox browser. :)

    Feel free to post your questions in case you bump similar issues in the future.

    Edz

  • Profile Image
    JotForm Support

    Answered by Goldo on March 06, 2012 at 08:52 AM

    Looks great kasperp.

  • Profile Image

    Answered by kasperp on March 06, 2012 at 08:56 AM

    Yeah - seems right now! Man am I excited about Jotform - really is an awesome and easy tool! 

     

    Thanks everyone!

  • Profile Image

    Answered by pinoytech on March 07, 2012 at 06:35 AM

    Your welcome kasperp.

    Feel free to contact us anytime if you need some assistance from us.

    Thank you for using JotForm!