Form won't submit - stuck on "please wait"?

  • Profile Image
    ike 
    Asked on April 25, 2016 at 08:46 PM

    Hi, as described - created form, everything looks OK - but when I'm testing the form, it doesn't work - I click submit, and then I get "Please wait".

    Can you please help?

  • Profile Image
    ashwin_d
    Answered on April 26, 2016 at 02:29 AM

    Hello,

    Have you solved this problem already?

    I did test your embedded form and I am not able to replicate the issue you are having. I was able to submit your form successfully. Please check the screenshot below:

     

    I would suggest you to please test your form again get back to us if the issue persists.

    Thank you!

  • Profile Image
    drainbolt
    Answered on April 26, 2016 at 09:39 AM

    I'm having the same problem as well. https://form.jotform.com/drainbolt/drf

  • Profile Image
    ike 
    Answered on April 26, 2016 at 10:44 AM
    I solved it - used iFrame for the embed.
    ...
  • Profile Image
    Kevin_G
    Answered on April 26, 2016 at 10:49 AM

    @drainbolt,

    I see that you opened multiple threads and posted on other user's threads as well: 

    https://www.jotform.com/answers/826641-Form-won-t-submit-please-help-launched-yesterday-#0

    https://www.jotform.com/answers/825112-The-form-stops-at-the-Please-Wait-submit-button-#2

    https://www.jotform.com/answers/823248-The-forms-on-my-website-wont-send-when-you-click-on-submit#3

    https://www.jotform.com/answers/826622-Form-not-submitting#0

    I see that one of us replied to you on this thread: https://www.jotform.com/answers/826601-I-get-a-Please-wait-message-when-trying-to-submit-the-form#1

    Please follow the advice provided on that thread and updates on that thread only, please do not open multiple threads for the same issue nor post the same on other threads, having only one thread per question or report helps us to assist you better and avoid us to reply on multiple threads.