What is JotForm?
JotForm is a free online form builder which helps you create online forms without writing a single line of code. No sign-up required.

At JotForm, we want to make sure that you’re getting the online form builder help that you need. Our friendly customer support team is available 24/7.

We believe that if one user has a question, there could be more users who may have the same question. This is why many of our support forum threads are public and available to be searched and viewed. If you’d like help immediately, feel free to search for a similar question, or submit your question or concern.


  • Profile Image

    Uploaded files are not sent to our Google Drive if email session and send post data is active

    Asked by arido on April 28, 2016 at 10:35 AM

    Hi there

     

    I've been reading about this issue I'm having, and it seems like it's happened before. My uploads are not routing to Google Drive which I feel like is a glitch with JotForm because I'm also running out of storage even though I deleted all submissions.

    Can someone take a look at my account please and clear the cache/uploads. It's all testing stuff, so I have no use for it. Hopefully this will resolve the Google Drive integration because it was working before.

     

    Thank you

    uploads stuck Submissions JotForm
  • Profile Image
    JotForm Support

    Answered by david on April 28, 2016 at 11:27 AM

    I checked your account and there is plenty of upload space remaining,  that should not be the issue.  We did have  few users report file upload issues yesterday, though I am currently unable to recreate the issue.  The Google Drive integration is also working as far as I can tell.  You may need to remove the integration and add it back again if it is no longer working on your end.

    If you continue to have issue with file uploads or the Drive integration, let us know and we will be happy to have another look.

  • Profile Image

    Answered by arido on April 28, 2016 at 04:54 PM

    hey, so i think i narrowed it down to the session id. when i don't redirect to the main form, the uploads go through, but if i go with the session id, only the pdf and google sheet is received.

    i disabled autofill, still no go. i have the send post data enabled for a few fields, but it's not necessary, and i can disable that, though i don't know how session would work then.

    currently my session id is set to {id} but i tried it with {email}-{id} {email}{id} and seems to be the same. i can't have it set to just email because i will have multiple submissions from the same email.

    i cleared the cache in my browser and profile, but seems not to work. although, i still have the running low on space message.

  • Profile Image

    Answered by Ben on April 28, 2016 at 05:13 PM

    The send post on submit option is not for use with sessions. It is to be used only if you want to have the form data submitted to your website which you have set as thank you page, as such this is likely the cause of the issue.

    What I would recommend is to remove send POST data from the first form and the second one unless you are using the second form to POST the data over to your website (for which I would still suggest turning it off and enabling webhooks instead.

    In regards to the sessions themselves, it is OK to use emails with IDs or any other combo. As long as the same request is made the session will be retrieved.

    Do let us know how it goes.

  • Profile Image

    Answered by arido on April 29, 2016 at 11:10 AM

    hey so i've disabled the send post data on both forms, as well as the auto save. this thing just wont go away. i don't know if this matters, but my main form redirects via thank you page, not with a link as was shown in the original guide. so instead of asking the user to click to go to the main form, they are redirected. i don't see this as a problem because the url is the same, but just wanted to mention it.

    i even removed the upload button and added it back.

    i set up a dummy form juts for file uploads and it sends images to drive just fine.

    is there some kind of a conditional that's jamming something or should i make a new form at this point? i mean, i can add another redirect at the end of this form specifically for file uploads, but i really don't want to do that.

  • Profile Image

    Answered by Ben on April 29, 2016 at 11:35 AM

    No, you should not need to set up another form just for file uploads.

    I will raise this to our developers to check it out and see what might be causing the same.

    As soon as they have any updates we will update you about it through this thread.

  • Profile Image

    Answered by arido on April 29, 2016 at 11:49 AM

    thanks a lot. something must be wonky with the session id because if i fill the main form out by itself the files go through, but when i use the entry form to redirect to it then the only thing that comes to drive is the pdf.

  • Profile Image
    JotForm Support

    Answered by david on April 29, 2016 at 12:23 PM

    Very odd indeed, we will let you know as soon as there is any further information from our developers.

  • Profile Image

    Answered by arido on May 03, 2016 at 12:31 PM

    is there any update on this issue? i am running short on time, and i still need to upgrade the account.

     

    thanks

  • Profile Image
    JotForm Support

    Answered by david on May 03, 2016 at 01:01 PM

    This ticket has been assigned to a developer and given a fairly high priority.  Though it does not look like they have had a chance to address the ticket yet, it should not be too much longer. 

  • Profile Image

    Answered by arido on May 18, 2016 at 10:02 AM

    hey, guys. any update on this?

  • Profile Image
    JotForm Support

    Answered by david on May 18, 2016 at 11:33 AM

    Unfortunately, there are no updates as of yet.  My apologies for the delay.  We will let you know via this thread as soon as there is any progress. 

  • Profile Image
    JotForm Support

    Answered by NeilVicente on June 12, 2016 at 03:33 AM

    Hi,

    Sorry for the late update, but we'd like to let you know that this bug is now fixed.

    Thank you very much for your patience.

    Best,