My form isn't displaying correctly

  • Profile Image
    jolizzy
    Asked on March 08, 2012 at 04:50 PM

    https://sites.google.com/site/swimtestsite12345/registration/sting-a-thon-pledge-form

    In Firefox, if I put the "submit" button at the bottom of the page, all the fields show up but the button disappears.  If I move the button up to the same line as telephone numbers, that whole section goes white.

    In IE, the "submit" button is cut off at the bottom of the page, although it does display correctly if I move it up a line.  I don't like the way it looks there.

    I also just noticed that one of my field names is cut off at the top of the form, so I assume it has to do with frames... but you can assume that I know NOTHING about code, so if there's a setting I need to change, I will appreciate if you would walk me through it.  Thanks.

     

    URL is with submit button to right of telephone

    screenshot is with submit button under telephone

  • Profile Image
    jolizzy
    Answered on March 08, 2012 at 05:03 PM

    I tried replacing the shrunken submit button with the full-sized one, but that doesn't make a difference.  The only thing that sort of worked was to break the form into 2 pages, but then I got a huge white block at the bottom... but at least the submit button displayed!

  • Profile Image
    Mike_T
    Answered on March 08, 2012 at 05:15 PM

    In Firefox, if I put the "submit" button at the bottom of the page, all the fields show up but the button disappears.

    Please try to increase the Widget height through its Properties in order to solve this problem. Please also note that Submit button should be used in full size mode.

    Thank you for cooperation.

  • Profile Image
    jeanettebmz
    Answered on March 08, 2012 at 05:29 PM

    Hello jolizzy!

     

    I would suggest you to try to embed the code to your site from the iFrame code icon, just copy it and paste it

    Here you have the guide

    http://www.jotform.com/help/67-So-Which-Form-Embed-Code-Should-I-Use

    also try to use the suggestions Mike_T is making to you about re-sizing the button to full mode. 

    Hope this work for you!
    Jeanette

  • Profile Image
    Mike_T
    Answered on March 08, 2012 at 05:48 PM

    I tried replacing the shrunken submit button with the full-sized one, but that doesn't make a difference. 

    It works from my side. Please follow the next steps:

    1. Remove your shrunken Submit button completely.

    2. Add the full size Submit button.

    3. Clear your browser cache, then re-check the site.

    4. Increase the Google Widget height if needed.

    If that does not work for you, please let us know.

  • Profile Image
    jolizzy
    Answered on March 09, 2012 at 03:47 PM

    MAN you people are good!  Thanks for being so good to a newbie.

  • Profile Image
    pinoytech
    Answered on March 12, 2012 at 11:04 AM

    Your welcome. Feel free to contact us anytime if you need further assistance.

    Thank you for using JotForm!