Form is not updating on my webpage after modifications

  • Profile Image
    jotformjoel
    Asked on May 02, 2016 at 09:30 PM

    Usually when I modify a Form it updated on the Site within a minute. I have modified the form Insight RSVP & Question, but it doesn't change on site. Please advise. Thanks!!

  • Profile Image
    Kiran
    Answered on May 02, 2016 at 11:23 PM

    The changes made to the JotForm should be instant and they'll be reflecting as soon as the form is saved. There shouldn't be any delay on the embedded form. The changes would be reflecting either when opened the form using the direct link or on the embedded page. I see what you mean on your form. I've tried adding a colon after address and see that the form with the direct link is displaying and on the webpage is not.

    It looks like there is an issue with the embedded script. Could you try removing the embedded script on the webpage and try re-embedding to see if that works? If it doesn't work, please try embedding using iframe embed code and let us know the results. We will be happy to take a look again for you.

  • Profile Image
    marcodelapena
    Answered on May 02, 2016 at 11:55 PM

    Hi there Kiran, I have the same situation, the changes are visible when I go to preview the form but they are not reflected on the published form 

    Here's the form:

    https://form.jotform.co/61227629846

    Thanks in advance for your help.

  • Profile Image
    Kiran
    Answered on May 03, 2016 at 12:08 AM

    @marcodelapena,

    I've moved your question to a separate thread and shall be addressed there shortly.

    https://www.jotform.com/answers/831355

    Thank you! 

  • Profile Image
    DrivePayments
    Answered on May 03, 2016 at 12:25 AM

    Yes mine is not updating at all either

  • Profile Image
    stevelack
    Answered on May 03, 2016 at 12:41 AM

    I am experiencing the same issue.  I changed from embed to iframe and that fixed it.  Then, when I make additional changes to the form, even the iframe embed is not updating.

  • Profile Image
    Kiran
    Answered on May 03, 2016 at 12:43 AM

    Thank you for updating us. It seems that there is an issue with displaying the updated form. We have already sent an alert to our backend team to take a look at this issue. Sorry for the inconvenience being caused. 

    As soon as the issue is fixed we'll update you here. Thank you for your patience and understanding.

  • Profile Image
    Kiran
    Answered on May 03, 2016 at 01:26 AM

    Thanks for being patient. The issue should be fixed by now. 

    Please check and let us know if the issue still persists. We are sorry for the inconvenience this may have caused.

    Thank you! 

  • Profile Image
    marcodelapena
    Answered on May 03, 2016 at 05:05 AM

    Awesome, I checked and it's all updated now. Thanks for your help, Kiran!

  • Profile Image
    ashwin_d
    Answered on May 03, 2016 at 06:10 AM

    Hello marcodelapena,

    On behalf of my colleagues, you are welcome.

    I am glad to know that your issue is resolved.

    Do get back to us if you have any questions.

    Thank you!

  • Profile Image
    melblueneon
    Answered on March 28, 2017 at 06:08 PM

    hi there,

    I'm having the same issue and people can now fill in my registration without filling in the boxes (95% of the fields are mandatory though)

    Here is my link thanks a lot for your help!

    https://form.jotformeu.com/70786455709368

    Mel

  • Profile Image
    Ian
    Answered on March 29, 2017 at 12:23 AM

    @melblueneon

    I created a separate thread for you to address the issue submitted by you.

    Please follow the thread at https://www.jotform.com/answers/1105103 to discuss  the issue further.

    You will be replied shortly on the new thread.