What is JotForm?
JotForm is a free online form builder which helps you create online forms without writing a single line of code. No sign-up required.

At JotForm, we want to make sure that you’re getting the online form builder help that you need. Our friendly customer support team is available 24/7.

We believe that if one user has a question, there could be more users who may have the same question. This is why many of our support forum threads are public and available to be searched and viewed. If you’d like help immediately, feel free to search for a similar question, or submit your question or concern.


  • Profile Image

    I am receiving blank submission from my form.

    Asked by Tyseank on May 03, 2016 at 11:50 AM

    Hi, I received a blank submission and I made a variety of the questions in my form a required field with hidden page breaks. Please let me know if this possible. 

    blank submission required field hidden and
  • Profile Image
    JotForm Support

    Answered by ashwin_d on May 03, 2016 at 01:45 PM

    Hello Tyseank,

    I did check your last edited form "Bangladesh Freelance Survey" and did not find any issue with that. You have configured your email alert correctly and the submission email should display all the answers.

    I did test your form by sending a test submission and the submission email which was sent  does display the input data correctly. Please check the screenshot below for the submission email :

    Can you please check the submission email you received and let us know if the submission data is being displayed correctly?

    Have you embedded your form in any webpage where you are having this issue with? Please share the webpage URL and we will take a look.

    We will wait for your response.

    Thank you!

  • Profile Image

    Answered by billflinn on May 03, 2016 at 01:52 PM

    Same problem.

    Link works perfectly except when I use it in a thank you link.

  • Profile Image
    JotForm Support

    Answered by KadeJM on May 03, 2016 at 03:08 PM

    @billflinn

    We understand you are experiencing a similar issue to this problem but I have moved your question to this thread here as a new problem for us to investigate for you separately.