Google Spreadsheet Integration: Blank label on the Matrix field and adding "#" in the column title stops the matrix field in the spreadsheet to update

  • Profile Image
    Asked on May 08, 2016 at 11:34 PM

    I apologize for the look of the form.  I am only in the testing of the integration phase and only put in the information that I needed to check so far.

    I tried posting earlier and I do not show that it has posted.  So I am trying again.  It said that my screenshot did not load.

    The information from the matrix on my form is not posting.  I have read several of the forum queries regarding integration issues with Google Spreadsheet.

    This is what I have done so far:

         - Removed Integration and connected to Google Spreadsheet (3 times)

         - Cleared my Cache in both Safari and Chrome

        - Removed Integration and connected to Google Spreadsheet again.

    Still not importing the information.  

    When I click on the "Edit Submission" link on the far right side of the the spreadsheet, the form shows the numbers are filled in on the Form.

    Can you help?

  • Profile Image
    Answered on May 09, 2016 at 03:28 AM

    It seems like this happens because of the symbol "#" in your column title AND that the matrix field does NOT have a label name on it.


    Try updating the column title, try naming it "Number of buds", also add a label on your matrix field after that, try making a test submission, that should automatically update your spreadsheet. No need to remove and re-add the integration for now. If that doesn't work, try re-integrating, but make sure to NOT use the "#" as the first character in your form title.

    Here's my test:

    1. Here you'll noticed that my matrix field does not have a label name, and the column title starts with a "#".

    2. When I make a first test submission, it goes through successfully without any problems. However, the succeeding submissions will show blank on the spreadsheet for the matrix rows.

    3. Here's my test submission:

    4. In my Google Spreadsheet, you'll noticed that "test11" does not show the inputs made on my matrix field.


    I have forwarded this bug to our developers. We will update you on this thread as soon as the problem has been resolved. For the meantime, please do try the suggestions above. Apologies for the inconvenience.