Form hanging at "Please wait" after clicking on Submit

  • Profile Image
    inbetweentheblinks
    Asked on May 09, 2016 at 02:46 PM

    I have embeded my form to my website (wordpress) and it looks great.  I just tried to fill out and submit the information but the "submit" button changes to "please wait..." and the form never goes through. 

    Screen grab attached

  • Profile Image
    Kiran
    Answered on May 09, 2016 at 03:51 PM

    It seems that you are using WordPress embed plugin to embed the form on your website which may be conflicts with the scripts on JotForm. Could you try disabling the plugin and embed the form using the default form embed code from the Publish wizard provided by JotForm?

    If the issue still persists, we request you to try embedding the form using iframe embed code. This method should not be having any conflicts with the scripts on your webpage.

    Hope this information helps! 

     

  • Profile Image
    inbetweentheblinks
    Answered on May 09, 2016 at 04:02 PM

    I did that originally on my website and nothing showed up so I used the WP option...since I do have a WP website.

    I switched it back to the regular embed code and nothing shows up

  • Profile Image
    inbetweentheblinks
    Answered on May 09, 2016 at 04:04 PM

    didn't see the comment below the image in your reply.  I tried the Iframe and that worked!

    thank you

  • Profile Image
    Kiran
    Answered on May 09, 2016 at 04:12 PM

    Great! I just tried submitting the form and see that the Thank you page is displayed. It's our pleasure to assist you. 

    Please do not hesitate to get in touch with us if you need any further assistance. We will be happy to help. 
     
    Thank you for using JotForm!!