What is JotForm?
JotForm is a free online form builder which helps you create online forms without writing a single line of code. No sign-up required.

At JotForm, we want to make sure that you’re getting the online form builder help that you need. Our friendly customer support team is available 24/7.

We believe that if one user has a question, there could be more users who may have the same question. This is why many of our support forum threads are public and available to be searched and viewed. If you’d like help immediately, feel free to search for a similar question, or submit your question or concern.


  • Profile Image

    Form conditions issue - Hidden fields showing

    Asked by beatsahead on May 09, 2016 at 02:50 PM

    start time should only show if I want to change the start time is selected, but it is showing on load.

    Page URL:
    https://form.jotform.co/60946887625876

    hidden selected start
  • Profile Image

    Answered by Huberson on May 09, 2016 at 04:34 PM

    Actually you have no conditions to show 'start time' if 'I need to change... start time' is check.

    There are two conditions linked to 'start time', since the field is already hidden, adding hidden conditions for it again is a problem, and even if the field was hidden when the form is loaded, it will only display if all two conditions match. 

     

    Since the field is already hidden initially, remove the HIDE blocks and use the conditions to only show the field when needed. Also avoid mixing SHOW and HIDE conditions as it can result in conflict. 

    Modified clone can be viewed here: https://form.jotform.com/61296689582978 

  • Profile Image

    Answered by beatsahead on May 09, 2016 at 04:51 PM

    I had deleted those conditions that you can see and they aren't showing up when I check through all the conditions.

    I don't know how you can see them and I can't, but I am unable to clone the form you've linked I get an error that it doesn't exist.

  • Profile Image
    JotForm Support

    Answered by BDAVID on May 09, 2016 at 06:51 PM

    Have you resolved this already? I just checked your form and the Start Time field works as expected: https://form.jotform.co/60946887625876 

    Let us know if you need more help, we will be glad to assist you.

  • Profile Image

    Answered by beatsahead on May 09, 2016 at 06:54 PM

    I'm not sure what is going on. It seems to be taking a long time for conditions put in place or removed to have any effect.

    On some of my forms yesterday all conditions were removed after I deleted one and I had to revert to a previous version of the form to get them back.

    But it does appear to be working as it should now.

  • Profile Image
    JotForm Support

    Answered by BDAVID on May 09, 2016 at 09:36 PM

    That's odd, but good to know it is properly working. Open a new thread if you need anything else, we will be glad to assist you.