None of our forms currently working - multiple websites

  • Profile Image
    Asked on May 11, 2016 at 08:16 PM

    A client emailed today that a form on their site was not displaying. I visited the page of the site with the form, and the form doesn't load. I tried to just browse the form link, and it will not load.

    After they contacted me, I checked two other sites using JotForm, and those forms are not loading either:

    On this page: I used the WordPress embed code and the form displays, but after clicking the submit button, there is an eternal "please wait" message. I also tried the iframe method on this page.

    SO - it appears that none of my client's jotforms are working -- different platforms (WordPress, DotNetNuke), tried multiple browsers and devices.

    I also just noticed that when I am in the form builder and click "preview" I can successfully fill out the form and hit submit and get a thank you, but if I click "open in a new tab" the page will not load.


  • Profile Image
    Answered on May 11, 2016 at 09:50 PM

    Hi Shelly,

    The 1st form was loading properly using its URL

    Same also for the other form


    I checked the website where the form was used. 

    When I test submitted the form on the website I was able to encounter the issue. The form will not submit and was stuck only to "Please wait..." on the submit.


    I found the caused to be the Wordpress embed code of the form.


    To fix, please try re-embedding the form on your WP website using instead the script embed code.

    Check this user guide: Adding-Forms-to-Wordpress-org-version

    Let us know if this still did not resolve the issue.







  • Profile Image
    Answered on May 12, 2016 at 04:29 PM

    Thanks for the reply - The links that displays for the form in form builder is different than the links you show above.

    FORM 1

    For the first form, when I click "Publish" - the link generated is, the link you show is -- which does work.

    I tried re-embedding the form on the page using the above link (this is a DotNetNuke site, so often the form tags compete, but I have not had an issue in the past using the basic code. I also tried the iFrame & source code methods. Nothing worked and caused problems on the page. I finally just linked to the form using the URL you provided (not the one generated from the form builder -- which doesn't work). I checked the form submissions and it looks like the form was functioning as recently as 5/3/16 because that was the date of the last submission.

    FORM 2

    I have not tested the form again, but I assume I would run into the same issue as the first scenario because it is also a DotNetNuke site. Nothing has changed on either of these sites.

    FORM 3

    On the site, I tried using the embed code script per the instructions, but the form will not load. -- (it is a site not a site).

    On this particular form, I received a submission as recently as 4/26/16, so it was working fine within the past few weeks. A new version of WordPress was released on 4/26 and 5/6, but I don't see anything in the changelogs that might have caused a new conflict.

    Thanks for any other suggestions you might have.



  • Profile Image
    Answered on May 12, 2016 at 04:57 PM

    I'm not sure if the issue is still there, I have checked your forms using the links you provided and I can see all of them are working now, I have also checked the form embedded o the website that you shred and I was able to submit it without any problem:

    If you have still issues try embedding your form using the default embed method, you do not need to change the link to the embedded form, this guide will help you with that:

    If this still persists, please provide us with the links to the webpages where the embedded forms are not being submitted, we will be glad to help.

  • Profile Image
    Answered on May 12, 2016 at 05:46 PM

    OK - the form is still not displaying on my Mac (Chrome or Firefox), but I can see it now on my Android phone, so it must be a Mac thing.

  • Profile Image
    Answered on May 12, 2016 at 06:04 PM

    I have tested the webpage on Chrome and Firefox using Mac and it is loading.



    There should be something blocking the form, would be good to check the web console, if there is something that does not allow the form to be displayed then it should be displayed there, the keyboard shortcuts below should help you to get the console on Chrome and Firefox:

    Chrome: Cmd + Opt + J

    Firefox: Cmd+Option+K