Not getting emails from any of my forms

  • Profile Image
    Dreamscapes
    Asked on May 12, 2016 at 06:04 PM

    When I send emails from any of my forms, they don't seem to be sent. Or at least I'm not receiving them. I can see the mails in the Inbox on the Jotform site, but I'm not receiving any. I've switched off all spam filters and even signed onto my mail server to see if I could find them there. It really seems as though Jot Form is not sending them. Emails sent from anywhere else do arrive at the same address to which JotForm is supposed to send the emails.

     

    Any help appreciated. 

    Martin

  • Profile Image
    Mike
    Answered on May 12, 2016 at 06:33 PM

    According to account email history, the messages are being sent.

    If you are successfully getting the messages from a 'TEST EMAIL' button, then you can use a noreply@jotform.com or noreply@formresponse.com Sender Email to receive the form email alerts in the same way as the test messages.

    You might also consider trying your own SMTP sender on form.

    How to Setup SMTP for a Form

    If you need any further assistance, please let us know.

  • Profile Image
    Dreamscapes
    Answered on May 14, 2016 at 02:20 PM

    Hello Mike

     

    Thank you so much for the quick reply. I eventually found a bug in the filtering options of my email service provider. I will follow up with them. But the tips above were exactly what I needed to troubleshoot this so I very much appreciate your help.

     

    Martin

  • Profile Image
    Jan
    Answered on May 14, 2016 at 03:42 PM

    Glad to know that you found the bug. On behalf of Mike, you are welcome. Please don't hesitate to contact us if you need any help. Thank you.