Only the first two out of four images are being uploaded in the Multiple file upload field

  • Profile Image
    Asked on May 16, 2016 at 06:04 PM

    Hi there,

    On my form I have a multiple image upload field.

    User can select up to 4 images.


    But when I view submissions only 2 of those images are being uploaded into jotform.


    How do I fix this?




  • Profile Image
    Answered on May 16, 2016 at 10:44 PM

    I assume you are referring to this form

    I sent a test submission to your form with 4 images. I checked the submissions page after and I can confirm that only 2 out of 4 images are being displayed.

    However, when I cloned your form and made the same tests, it appears that the 5 images are received correctly.

    To resolve the issue with the uploads on your form, please try clearing your form cache. Here's how: How To Clear Form Cache

    If the issue still persists, please let us know.

  • Profile Image
    Answered on May 17, 2016 at 03:21 AM

    Thanks for looking into this.

    I have cleared cache but something it still not quite right.

    For the multiple image upload field. The last image is always ignored.

    If I select 4 images only 3 are uploaded. If I select 3 images, only 3 are uploaded.


    Thanks in advance.

  • Profile Image
    Answered on May 17, 2016 at 04:34 AM

    I made another test submission to check further. It appears that clearing the form cache has resolved the issue. I submitted 4 images and I was able to see the 4 images in your submissions page.

    Can you please check on your end to confirm that the 4 images have been received? I will wait for your response.

  • Profile Image
    Answered on May 17, 2016 at 05:05 AM

    I'm afraid not.


    When I look at your submissions, you submitted 1 at 9.23 which shows 4 images.

    You submitted another at 9.29 which shows only 3 images.

    I tried submitting another myself and I'm not getting the Featured Image OR the last gallery image (only 3 out of 4 gallery images).

  • Profile Image
    Answered on May 17, 2016 at 06:29 AM

    I thought it may be worth mentioning that my host did some work on my htaccess file and another related file.

    Not sure if anything here could be causing conflict?



    suPHP_ConfigPath /var/sites/p/

    RewriteEngine On

    RewriteCond %{HTTP:X-Forwarded-Proto} !https

    RewriteRule ^(.*)$$1 [R=301,L]

    AddType x-httpd-php56 .php



    AND php56.ini...


    engine = On

    zend.ze1_compatibility_mode = Off

    short_open_tag = On

    asp_tags = Off

    precision    =  12

    y2k_compliance = On

    output_buffering = Off

    zlib.output_compression = Off

    implicit_flush = Off

    serialize_precision = 100

    safe_mode = Off

    disable_functions =


    expose_php = Off

    max_execution_time = 60     ; Maximum execution time of each script, in seconds

    max_input_time = 6000 ; Maximum amount of time each script may spend parsing request data

    memory_limit = 128M      ; Maximum amount of memory a script may consume (128MB)

    error_reporting  =  E_ALL & ~E_NOTICE

    display_errors = On

    display_startup_errors = Off

    log_errors = Off

    log_errors_max_len = 1024

    report_memleaks = On

    track_errors = Off

    variables_order = "EGPCS"

    register_globals = Off

    register_argc_argv = On

    auto_globals_jit = On

    upload_max_filesize = 100M

    post_max_size = 100M

    magic_quotes_runtime = Off

    magic_quotes_gpc = Off

    magic_quotes_sybase = Off

    auto_prepend_file =

    auto_append_file =

    default_mimetype = "text/html"

    extension_dir = "/usr/newage/lib/php/extensions/no-debug-non-zts-20131226"

    enable_dl = Off

    file_uploads = On

    upload_tmp_dir = /tmp

    allow_url_fopen = On

    allow_url_include = On

    default_socket_timeout = 90

    date.timezone = Europe/London

    mysql.allow_persistent = On

    mysql.max_persistent = -1

    mysql.max_links = -1

    mysql.default_port =

    mysql.connect_timeout = 90

    mysqli.max_links = -1

    mysqli.default_port = 3306

    mysqli.default_socket =

    mysqli.default_user =

    mysqli.default_pw =

    mysqli.reconnect = On


    session.save_handler = memcache

    session.save_path = "tcp://"

    session.use_cookies = 1 = PHPSESSID

    session.auto_start = 0

    session.cookie_lifetime = 0

    session.cookie_path = /

    session.cookie_domain =

    session.cookie_httponly = 

    session.serialize_handler = php

    session.gc_probability = 0

    session.gc_divisor     = 100

    session.gc_maxlifetime = 14400

    session.bug_compat_42 = 1

    session.bug_compat_warn = 1

    session.referer_check =

    session.entropy_length = 0

    session.entropy_file =

    session.cache_limiter = nocache

    session.cache_expire = 180

    session.use_trans_sid = 0

    session.hash_function = 0





  • Profile Image
    Answered on May 17, 2016 at 06:45 AM

    Also - I just tried a completely new test form on a new page of my site.

    I have embedded the form using:

    <script type="text/javascript" src=""></script>


    Similar/Same issue occurs.

    Featured image is uploading but only 2 out of the 4 multiple images are uploading.

  • Profile Image
    Answered on May 17, 2016 at 10:12 AM

    The HTACCESS and PHP files are part of your website and I don't think the changes to the files would cause you the problem. 

    I have tested your form and can confirm the issue is there. I have tried changing your form settings such as disabling the image validation, disabling the send post (which I suggest keeping it disabled since the form, as far as I could see it, is not using anything related to it such as redirect to custom PHP page). 

    I have forwarded this thread to our developers for them to investigate further. We'll let you know here for our findings.

  • Profile Image
    Answered on May 17, 2016 at 10:17 AM

    Thanks for getting back to me.

    I had send post data enabled as the form integrates (I think via a web hook) and auto-completes a custom post type on my wordpress backend.

    The test form above doesn't have this function as I was trying to find root cause but the real form (see first post) where issues was discovered does need that enabled.

    Thanks very much - Look forward to hearing from you.

  • Profile Image
    Answered on May 17, 2016 at 11:36 AM

    You're welcome. Thank you for the explanation. Yes, if you are integrating with Webhook, you need to enable the Send Post. 

    I have already forwarded this thread to our developers. If there are updates, you should know it through this thread.

  • Profile Image
    Answered on May 18, 2016 at 04:41 AM

    Not sure if this helps but I have an update.

    If remove the multiple file upload button and replace it with single file upload buttons then all images do get through.

    Unfortunately that ruins the styling on my form as the single image buttons are not customisable.

    I have tried switching these to multiple but allow only 1 in settings - But this causes the problem to return.

  • Profile Image
    Answered on May 18, 2016 at 05:46 AM


    We have found out the cause of this issue and we're fixing it the soonest time possible.

    We apologize for the inconvenience this may have caused. You will be informed as soon as the problem is rectified.


  • Profile Image
    Answered on May 18, 2016 at 10:55 AM


    The issue has been rectified. Multi-file uploads should now work as intended.


  • Profile Image
    Answered on May 18, 2016 at 04:35 PM

    Hi - Thanks very much.

    All files are now uploading :)


    Thanks very much for the fix - Really appreciate it!!