What is JotForm?
JotForm is a free online form builder which helps you create online forms without writing a single line of code. No sign-up required.

At JotForm, we want to make sure that you’re getting the online form builder help that you need. Our friendly customer support team is available 24/7.

We believe that if one user has a question, there could be more users who may have the same question. This is why many of our support forum threads are public and available to be searched and viewed. If you’d like help immediately, feel free to search for a similar question, or submit your question or concern.


  • Profile Image

    Form not submitting due tor *required widget validation

    Asked by T4L_Admin on May 16, 2016 at 10:06 PM

    I have a form that requires a response from each input. When i complete the form and click submit it takes a while to load before sending me to a page that says i have missed some sections. Can you please review my form to try and find an error as i cannot seem to find anything that is incorrect.

    Note that on the first page the name and email fields will be self populated from url parameters. 

     

    Page URL:
    https://form.jotform.co/61290973917869

    form not submitting sections required widget validation
  • Profile Image
    JotForm Support

    Answered by jonathan on May 17, 2016 at 02:08 AM

    Please set to OFF the *Required validation option for the Form Tabs widget on the form https://form.jotform.co/61290973917869

     

    That should fix the issue. Let us know if not.

    Thanks.

     

  • Profile Image

    Answered by T4L_Admin on May 17, 2016 at 05:42 AM

    I believe that will work. Is there anyway to speed up the validation process? It takes a very long from the time that submit is pressed. The submit text changes to "please wait..."

  • Profile Image
    JotForm Support

    Answered by beril on May 17, 2016 at 09:43 AM

    I've cloned and tested your form I am not able to reproduce the same issue that you’re having. Your  form is too long.=) Because of that reason, you are waiting nearly ten seconds when you submit your form and it is normal.

    Here is how it works on my side:

    Can you try to uncheck the 'Save on data changes' from preferences?

    If you have any question or issues, please do not hesitate contacting us. We will be glad to assist you.