Problem with optional file upload fields

  • Profile Image
    eSTUDENT
    Asked on May 17, 2016 at 02:51 PM

    Hi,

    I've created a form which contained 4 file upload fields. 3 of them where required and 1 was optional. 

    Since I know people that have been uploading files they have added files to optional fields but in few cases, those files were not uploaded. 

    Can you explain what happened?

  • Profile Image
    victor
    Answered on May 17, 2016 at 04:24 PM

    When reviewing your form, 61305914385355, I noticed that you have 5 upload fields. All where required. I am assuming that you just modified this recently.

    If this is not the form in question, please let us know.

     

  • Profile Image
    eSTUDENT
    Answered on May 17, 2016 at 05:06 PM

    That is't the form that I had problem with.

    The problem is with form:61286549104356

     

     

     

  • Profile Image
    victor
    Answered on May 17, 2016 at 06:37 PM

    I have tested your form and could not replicate any issues with the upload field.

    Since this field is not required, is it possible few users did not upload additional files?

    If you have any question or issues with this field, please let us know. We will be glad to take another look.

  • Profile Image
    eSTUDENT
    Answered on May 17, 2016 at 06:45 PM

    Users did upload files but form didn't save them, this happened to few users between 2016-05-15 23:56:46 and 2016-05-16 00:01:19

    Also, users reported that form was very slow.

    And I have embedded form to my website via javascript tags, users didn't have a direct link to form.

  • Profile Image
    Kiran
    Answered on May 18, 2016 at 01:17 AM

    Could you try disabling the option "Allow Multiple" option for the optional file upload on your JotForm and see if that works?

    Please check and let us know if the issue still persists. I'm also further investigating the issue and I'll get back to you if I found any useful information.

    Thank you! 

  • Profile Image
    Kiran
    Answered on May 19, 2016 at 02:26 AM

    Unfortunately, we observed an issue with Multi-file uploads failing randomly from EU servers. However, the issue was then fixed by our backend team. Please check now and let us know if the issue still persists. We will be happy to take a look again. Sorry for the inconvenience this may have caused.

    Thank you!