My Campaign Monitor Integration suddenly stopped working

  • Profile Image
    Adam Falla
    Asked on May 18, 2016 at 01:14 PM

    Hi,

    I have a number of forms in my account that are integrated with Campaign Monitor so that when a user submits information using the form, they are added to mailing list in Campaign Monitor.

    This was working perfectly until early February but since then - despite the integration status saying that it is live, no users are being added to the mailing lists.

    I have contacted support at Campaign Monitor and they say the lists in question are not linked to a JotForm and suggested I ask here if there is a solution?

    Please let me know.

    Best

    Adam Falla

     

  • Profile Image
    Ben
    Answered on May 18, 2016 at 02:40 PM

    If I understood you correctly Adam, you are integrating your form to Campaign Monitor and each time you are shown the success confirmation however the integration is not actually made to Campaign Monitor?

  • Profile Image
    AirCleanNSheen
    Answered on May 18, 2016 at 03:44 PM
    Correct, the user’s email address is not being added to the list, and staff at Campaign Monitor can see no evidence of the integration.
    ...
  • Profile Image
    Ben
    Answered on May 18, 2016 at 05:28 PM

    Thank you for the confirmation.

    I have checked your form and I see that you have created the integration, but it seems that no fields were added that should be passed over to the list - as you can see here:

    That is the reason why your form is not passing the details over.

    What I would suggest is to go back to the integration and edit the same. Once there, do set the fields and then click on the complete integration button.

    After that your integration should be working properly.

    Do of course let us know how it goes Adam.