I click on the box secure form in embeded option, but it doesn't save with check mark

  • Profile Image
    smart1work
    Asked on March 15, 2012 at 03:22 AM

    my forms are saving as non-secure.....they were saving correctly as secure but now the check mark is not saved and won't save.

  • Profile Image
    abajan
    Answered on March 15, 2012 at 05:00 AM

    Whenever a form is saved in its non-secure format, a secure version should also be automatically available, whether Secure form is checked or not. That box is just there as a convenience, so that you won't have to manually change the URL in the embed codes provided by the wizard. (I'm not in the habbit of using that check box but from what I can recall, if it is checked and the Embed Form Wizard is then closed, when the wizard is re-opened the check mark (tick) won't be there. However, if you sign in to the secure version of the form builder (https://secure.jotform.com), all of the codes provided by the Embed Form Wizard will be in the the secure format, whether the "Secure form" box is checked or not.

    The only difference I can spot between the two versions of your form is that whereas there's a space at the top and bottom of the secure one, none is displayed at the non-secure one. Those spaces are where the security seal should be. When a security seal is included on a form, it will only be displayed at the secure URLs. (Since the regular address of the form is not secure, the seal won't be displayed there.)

    As to why the seal isn't being displayed at the secure address, we no longer use the GlobalSign seal. It has been replaced by RapidSSL. Let me check on something and get back to you.