I am having major issues with the FTP integration

  • Profile Image
    Asked on May 26, 2016 at 03:08 PM
    Also, I am having major issues with the FTP integration. In some cases (usually with bigger files) I receive a notification email that someone has filled out the form but the file on my FTP is incomplete. It only uploads part of the file. Also,the PDF form attached to the email, when working correctly, has the download links to the files included. In the instances in which the file does not fully upload, there is no link in the PDF. Do you know why the files are not completely uploading to my FTP or have any ideas on what to try?
  • Profile Image
    Answered on May 26, 2016 at 03:46 PM

    How large were the files that were partially uploaded? I have inspected your form and I saw that you have set Max Total Upload Size to 500MB for upload field. However please note that you might need to have a paid account to get this working, free accounts only allow a total amount space of 100 MB.

    You can see this note inside of this guide: https://www.jotform.com/help/33-Changing-the-Upload-Size-Limit 

    Hope this will help. let us know if you need further assistance. 


  • Profile Image
    Answered on May 26, 2016 at 04:12 PM

    The last file it happened with was 72.9MB, it only got to 31.9MB. It has worked perfectly fine with files that are larger than that. It doesn't seem to be a size issue because there is such a big range in the point at which it stops. We are willing to go to a paid account, but not without first seeing that it will work correctly with our FTP. 

  • Profile Image
    Answered on May 26, 2016 at 06:10 PM

    If the file link is missing in submission details and PDF file, it usually means that file was not properly uploaded to our server. It might be related to unreliable user's internet connection, browser errors, problem with the file itself or other reasons.

    Also, for large uploads (if a single file is bigger than 100MB) we suggest using upload fields in a single file upload mode.

    Thank you.

  • Profile Image
    Answered on May 27, 2016 at 08:44 AM

    The file I mentioned was uploaded as a single file. I was able to retrieve it from your server so I know that it successfully uploaded and was not an Internet connection issue. The problem is happening in the transfer from your server to our FTP. It cannot be a size issue or timeout issue with our FTP because we have clients uploading much larger files directly to our FTP without any issue.

  • Profile Image
    Answered on May 27, 2016 at 09:48 AM

    So you mean that these files after being uploaded and transferred through ftp upload to be passed over to your server are not working correctly?

    Thank you for the additional information about this problem and please some extra time if you don't mind so that we may investigate this problem more to get to the bottom of this issue.

  • Profile Image
    Answered on May 27, 2016 at 10:01 AM

    Here is a scenario that happened last week:

    A customer completed our form that is embedded on our website and uploaded a single file (PDF, 72.9MB).

    I received the confirmation email from jotform that they had completed the form. However, typically there is a link included to download the file, this link was not included.

    I also received an FTP notification email that files had been uploaded to our FTP (the file the customer had uploaded as well as the PDF jotform submission form).

    I accessed our FTP to retrieve the file and noticed that two folders had been created with two different unique jotform submission numbers. One folder had the PDF submission form (it also did not have a download link or file name included) and the other folder had the file which failed to open. It had only loaded 31.9MB.

    When I check our FTP logs it does not show any errors for timeout.

    I was able to use a previous submission form that included a download link and changed the file name in the link to the name of the file that unsuccessfully loaded. The file then successfully downloaded from your server. However, this is the only way I was able to get the file. I was not even able to access it from my jotform account.

    This same scenario has happened multiple times over the past couple of months. I'm hoping we can find a fix because I really like the form when it does work correctly.

  • Profile Image
    Answered on May 27, 2016 at 10:51 AM

    I can understand that the file seems to be incomplete when it is sent to your FTP server, and the link does not appear in the submission PDF file that is generated. 

    I tried to find the submission where this file was uploaded, but seems like you have cleared your submissions since all your forms currently don't have submissions. 

    I'm currently testing this, I'm uploading a file of 81.7 MB, if I'm able to replicate the issue, I will let you know here, since with small files it is working just fine. 

    If possible provide us the details of the submission where this happened or try to upload a file again, if the issue is still there, please let us know. 

  • Profile Image
    Answered on May 27, 2016 at 11:33 AM

    Update ~

    Kevin & I have both spent some time testing this even though I was testing this thoroughly prior to him checking it after my last response to you about the issue.

    I checked this myself a few times with an external ftp host setup outside of jotform and my results were successfully the same. Kevin on the other hand tested this with jotform ftp which even though that setup functions internally on our end it means it might not be the server but something else.

    Both of our tests confirmed that currently we are not able to replicate this problem since right now it seems to be working and uploading the files through ftp correctly at this time.

    Additionally, our files are slightly larger. than the file you last described His was about 81mb and mine was about 86mb. We also received the pdf alongside it.

    What file types are being uploaded that you are having this issue with inparticularly?

    Also, what file host is being used to send these ftp uploads to through to?

    Do you have any upload limits set for the host? Such as bandwidth and upload size?

    May we have your permission to obtain one of these files from you? If so then which?

    This way we can test this problem more accurately on our end to check it further.