File upload field doesn't react in App

  • Profile Image
    Asked on May 31, 2016 at 03:08 AM

    Hello support team,


    The Jotform doesn't work on Samsung Galaxy Tab3 and Samsung S4 mini 

    Can you please help me?




  • Profile Image
    Answered on May 31, 2016 at 03:53 AM

    I downloaded your app using my Android device but the upload button seems to work fine. When I click the button, the file picker option is shown.


    Does this happen on Samsung devices only? Can you try the app on other device and see if it is working there? It might be possible that your app where you have embedded the form is blocking some of the resources of the form like JS scripts. Please try to debug your app and see if there are errors in the console.

    You can also try re-embedding the form in your app using the iFrame embed code. To get your form's iFrame code, you can check this article: Getting the Form iFrame Code and see if this will helps.


    Do let us know if the issue still persists.

  • Profile Image
    Answered on May 31, 2016 at 02:45 PM
    Hi Chriistian,
    Thanks for your quick reply.
    I did the test with iFrame like you suggested but I still have the same
  • Profile Image
    Answered on May 31, 2016 at 03:51 PM

    Have you tried debugging the application to see if there is any error that could give an idea about the source of your issue. Since the form is inside an Android application, we cannot really troubleshoot from the app.

    You should also test it on devices other than Galaxy tab/S4 mini, to see if the error is specific to some devices/platform.

  • Profile Image
    Answered on May 31, 2016 at 05:42 PM

    Hi Huberson,

    I did some testing with iFrame on Appsgeyser and now it gives same issue on my phone too. It is an Samsung Note 3


    Your users can download your app from:        

    Short url:




  • Profile Image
    Answered on May 31, 2016 at 07:25 PM

    Unfortunately, I'm also not having a tablet to test the App. However, I have tried accessing the form from the App on my phone and seems to be working fine at my end. It looks like the issue is accessing the form on a Tablet. Since the form is working fine on mobile phones, it doesn't look like a conflict. Could you check if the File upload is working while accessing the form in a browser on the tab? Please try accessing the form using the same orientation and let us know the results.