What is JotForm?
JotForm is a free online form builder which helps you create online forms without writing a single line of code. No sign-up required.

At JotForm, we want to make sure that you’re getting the online form builder help that you need. Our friendly customer support team is available 24/7.

We believe that if one user has a question, there could be more users who may have the same question. This is why many of our support forum threads are public and available to be searched and viewed. If you’d like help immediately, feel free to search for a similar question, or submit your question or concern.


  • Profile Image

    Voice recorder widget not saving recorded file when using FireFox

    Asked by jbusick on June 01, 2016 at 02:59 PM

    Hi,

    I built a test form that can ask a quiz answer and have the user speak, record and send the answer to us when they hit submit.  When we test this form, even with only a few seconds of audio, it never saves.  It just sits there and says "saving" indefinitely.  

     

    Page URL:
    https://form.jotform.com/61524514270145

    voice recorder not saving
  • Profile Image
    JotForm Support

    Answered by Mike on June 01, 2016 at 03:16 PM

    Which browser have you used to test the Voice Recorder widget?

    The saving seems to be working fine in Google Chrome and Opera, but failing in Firefox on my side.

    We will forward a bug report ticket to our developers about this issue.

  • Profile Image

    Answered by jbusick on June 01, 2016 at 03:45 PM
    Thanks. I’ve tried Safari and Firefox, no luck.
    Jamin Busick
    Sales Manager | Professional | Retail
    Cell: (505) 228-3486
    Email: jamin.busick@naturalhi.com
    NHI: Website - Facebook  - Twitter 
    HCS: Website - Facebook - Twitter
    Femmenessence: Website - Facebook
    ...
  • Profile Image
    JotForm Support

    Answered by david on June 01, 2016 at 04:22 PM

    I am also able to reproduce the issue in FireFox on my end.  I receive the following errors in FireFox:

    However, in Chrome, there is no issue accessing the recorder device and saving the recording.

    I will forward this to our developers to have a closer look.  For the time being, I would recommend to your users that they use Chrome if possible.

  • Profile Image
    JotForm Support

    Answered by TitusN on August 19, 2016 at 06:06 AM

    We've made some updates to the widget which should fix the issue you're experiencing. 

    Could you check? Let us know. 

  • Profile Image

    Answered by jbusick on August 19, 2016 at 09:45 AM
    Hi. It’s worse now, it doesn’t ever record. Thanks.
    Jamin Busick
    Sales Manager | Professional | Retail
    Cell: (505) 228-3486
    Email: jamin.busick@naturalhi.com
    NHI: Website - Facebook  - Twitter 
    HCS: Website - Facebook - Twitter
    Femmenessence: Website - Facebook
    ...
  • Profile Image
    JotForm Support

    Answered by TitusN on August 19, 2016 at 10:08 AM

    Thank you, we really appreciate the feedback. 

    We're checking that out. 

  • Profile Image
    JotForm Support

    Answered by widgets on August 19, 2016 at 10:20 AM

    @jbusick Hi sorry about that, can you elaborate further? What browser you are using? What part of the process is not working? Are you seeing a "Recording in progress" message below the widget when you start the recording?

    I just look at your form and tested the widget and its working fine. Your browser probably cached the old files. Can you try clearing your browser cache. There are guides from here if you're not sure what to do.

    Do let us know if the problem still persist.

    Regards,
    Widget Team

  • Profile Image

    Answered by jbusick on August 19, 2016 at 10:45 AM
    This would be dynamite if you guys get it to work. Sales companies could use to get people to submit their “pitch” in a recording instead of a text or multiple choice response.
    When I tried the app a few days ago, it appeared to work (Safari, Firefox) but it would sit spinning forever after recording and never let you hit submit.
    Thanks,
    Jamin Busick
    Sales Manager | Professional | Retail
    Cell: (505) 228-3486
    Email: jamin.busick@naturalhi.com
    NHI: Website - Facebook  - Twitter 
    HCS: Website - Facebook - Twitter
    Femmenessence: Website - Facebook
    ...
  • Profile Image
    JotForm Support

    Answered by widgets on August 19, 2016 at 11:07 AM

    @jbusick. Thank you for that information. Have you tried my suggestions? Can you answer them if you don't mind. We need those information to further check whats the real problem on your side. It actually "works" when we tried your form - unless it's a different form. It could be your browser, which why it appears that its not working. Here is a simple demo of your form I just captured.

     

    Regards,
    Widget Team

  • Profile Image

    Answered by jbusick on August 19, 2016 at 11:45 AM
    Hmm.
    This is what I see in Safari or Firefox. I never get the option record. This is after clicking record.
    Jamin Busick
    Sales Manager | Professional | Retail
    Cell: (505) 228-3486
    Email: jamin.busick@naturalhi.com
    NHI: Website - Facebook  - Twitter 
    HCS: Website - Facebook - Twitter
    Femmenessence: Website - Facebook
    ...
  • Profile Image

    Answered by jbusick on August 19, 2016 at 11:45 AM
    You are right, I cleared the cache in firefox and it worked. Let me test Safari now.
    Jamin Busick
    Sales Manager | Professional | Retail
    Cell: (505) 228-3486
    Email: jamin.busick@naturalhi.com
    NHI: Website - Facebook  - Twitter 
    HCS: Website - Facebook - Twitter
    Femmenessence: Website - Facebook
    ...
  • Profile Image

    Answered by jbusick on August 19, 2016 at 11:45 AM
    I have too many windows open for a meeting this morning so I can’t clear Safari cache at the moment. Have you tried it in Safari? I can try after my meetings but that will be a couple hours.
    Thanks, this is really exciting. You rock.
    Jamin Busick
    Sales Manager | Professional | Retail
    Cell: (505) 228-3486
    Email: jamin.busick@naturalhi.com
    NHI: Website - Facebook  - Twitter 
    HCS: Website - Facebook - Twitter
    Femmenessence: Website - Facebook
    ...
  • Profile Image
    JotForm Support

    Answered by david on August 19, 2016 at 12:52 PM

    I checked Safari in an emulator and the widget does not appear to be working, though it may be due to the emulator not having access to the microphone.  Let us know if the widget still does not work in an actual Safari browser and we will be happy to have another look.

  • Profile Image

    Answered by jbusick on August 24, 2016 at 09:45 AM
    Good morning,
    Okay, so I cleared cache, history and restarted Safari and it still doesn’t work unfortunately. After clinking record, the space below the record button expands, but then nothing ever happens. Thanks,
    Jamin Busick
    Sales Manager | Professional | Retail
    Cell: (505) 228-3486
    Email: jamin.busick@naturalhi.com
    NHI: Website - Facebook  - Twitter 
    HCS: Website - Facebook - Twitter
    Femmenessence: Website - Facebook
    ...
  • Profile Image
    JotForm Support

    Answered by beril on August 24, 2016 at 11:08 AM

    I was also replicate the same issue on my side. If I click on the record it doesn't work on Safari.

    To solve that issue, I've deleted the widget and added again. At that situation it worked as expected as you see below:

     

    We would appreciate it if you could also test it on your side and let us know the result. We will wait for your response.

  • Profile Image
    JotForm Support

    Answered by beril on August 24, 2016 at 11:16 AM

    I noticed that I've sent the wrong gif file. Here is how it works after deleting and re-adding the widget on my side:

     

  • Profile Image

    Answered by jbusick on August 24, 2016 at 11:45 AM
    Hmm, still not working on my end. I deleted and re-downloaded and made a “new” form to test it. I cleared cache in Safari. p.s., what do you use to screen record like that????
    Thanks. You guys are awesome for working so much on this.
    https://form.jotform.com/62364393926161
    Jamin Busick
    Sales Manager | Professional | Retail
    Cell: (505) 228-3486
    Email: jamin.busick@naturalhi.com
    NHI: Website - Facebook  - Twitter 
    HCS: Website - Facebook - Twitter
    Femmenessence: Website - Facebook
    ...
  • Profile Image
    JotForm Support

    Answered by widgets on August 24, 2016 at 12:03 PM

    @jbusick. Thank you for updating us. There is also one thing I would like to ask if you don't mind doing it for a couple of minutes.

    When you open your form on Safari. Before you record could you please press the F12 on your keyboard to bring up the Developer tools. If it doesn't work you can right click on the form(anywhere in the form). Then select "Inspect Element". After that go to Console Tab and take a screenshot for us. You can directly paste your screenshot on this thread, it will be uploaded automatically.

    There might be something in there that could help us track your problem. I tried on all safari browsers I have, both windows and MacOs version and they are all working fine.

    Thank you for your cooperation, looking forward.
    Widgets Team

  • Profile Image

    Answered by jbusick on August 24, 2016 at 12:45 PM
    No problem.
    Here’s the elements tab.
    And here is the console tab:
    Jamin Busick
    Sales Manager | Professional | Retail
    Cell: (505) 228-3486
    Email: jamin.busick@naturalhi.com
    NHI: Website - Facebook  - Twitter 
    HCS: Website - Facebook - Twitter
    Femmenessence: Website - Facebook
    ...
  • Profile Image
    JotForm Support

    Answered by widgets on August 24, 2016 at 01:22 PM

    @jbusick sorry but we don't see any images. Can you try to reupload?

  • Profile Image

    Answered by jbusick on August 24, 2016 at 01:45 PM

    Jamin Busick
    Sales Manager | Professional | Retail
    Cell: (505) 228-3486
    Email: jamin.busick@naturalhi.com
    NHI: Website - Facebook  - Twitter 
    HCS: Website - Facebook - Twitter
    Femmenessence: Website - Facebook
    ...
  • Profile Image
    JotForm Support

    Answered by david on August 24, 2016 at 02:03 PM

    If you are replying via email, screenshots cannot be attached to the email.  If you wouldn't mind attaching the screenshot directly to the forum post:

    https://www.jotform.com/answers/414264-How-to-include-screenshot-image-in-the-support-forum

    It would be much appreciated.

    https://www.jotform.com/answers/851607

  • Profile Image

    Answered by jbusick on August 24, 2016 at 02:45 PM
    Cool, just posted the consol tab and the elements tab images.
    Jamin Busick
    Sales Manager | Professional | Retail
    Cell: (505) 228-3486
    Email: jamin.busick@naturalhi.com
    NHI: Website - Facebook  - Twitter 
    HCS: Website - Facebook - Twitter
    Femmenessence: Website - Facebook
    ...
  • Profile Image
    JotForm Support

    Answered by Mike on August 24, 2016 at 03:03 PM

    @Jbusick,

    We have received your screenshot of the site elements, but we also need a screenshot from the console tab. Please include it to this thread.

    https://www.jotform.com/answers/851607

    Please also note that the widget is based on Adobe Flash, so you need an Adobe Flash Player installed in your system. You should make sure that you run the latest Adobe Flash Player version available for your system, and also the Flash plugin should be allowed in your Safari.

  • Profile Image

    Answered by jbusick on August 24, 2016 at 03:07 PM

     

  • Profile Image
    JotForm Support

    Answered by david on August 24, 2016 at 03:14 PM

    Thank you, that is what we were looking for.  We will let you know when we have any further updates.

  • Profile Image
    JotForm Support

    Answered by widgets on August 25, 2016 at 05:47 AM

    @jbusick Thank you for the screenshot. Could you please try it again, and see if you still experiencing the same problem. We made some updates on the widget. Hopefully this will solve the problems you were having. Let us know. Also make sure that your microphone is available and not in use. For example by other browsers or applications.

    Regards,
    Widget Team

  • Profile Image

    Answered by jbusick on August 25, 2016 at 10:45 AM
    Hi,
    Still doesn't work unfortunately. I even cleared cache and deleted and reinstalled the widget. When I click record, the white space below record expands, but it never records (elapsed time stays at 0) and nothing ever happens…
    Thanks,
    Jamin Busick
    Sales Manager | Professional | Retail
    Cell: (505) 228-3486
    Email: jamin.busick@naturalhi.com
    NHI: Website - Facebook  - Twitter 
    HCS: Website - Facebook - Twitter
    Femmenessence: Website - Facebook
    ...
  • Profile Image
    JotForm Support

    Answered by widgets on August 25, 2016 at 11:03 AM

    @jbusick. I'm sorry to hear that. Can you please upload another screenshot of the problem, just like the previous image your sent. Also I would like to know what version of MacOS you are using and what version of safari browser. Looking forward for this informations.

    Regards,
    Widget Team

  • Profile Image

    Answered by jbusick on August 25, 2016 at 11:08 AM

    Here you go.

    MacOS 10.11.6

    Safari 9.1.2

     

  • Profile Image
    JotForm Support

    Answered by widgets on August 25, 2016 at 11:53 AM

    @jbusick. Thank you and I appreciate for being patience to resolve this. Can you try this out again. In case it doesn't work. Please take another screenshot for me. I'm relying on your images to determine the real cause of the problem. I hope that's okay with you.

    Regards,
    Widget Team

  • Profile Image

    Answered by jbusick on August 25, 2016 at 02:40 PM

    No problem, I'm just happy and impressed with your help.  Here are two screenshots, one before clicking the record, and one after.  

     

    Before:

     

    And after clicking record:

  • Profile Image
    JotForm Support

    Answered by widgets on August 26, 2016 at 05:54 AM

    @jbusick. Thanks. I guess we need to have an extensive debugging process. I hope you're fine with that. We added more debug messages on the console tab that could probably help us find the cause. Try to clean your browser cache again and test then upload another screenshot if still failing. 1 image is enough.

    Also I would like to confirm if they are working just fine from your other browsers?

    Regards,
    Widget Team