Jot2Tweet app does not work

  • Profile Image
    Asked on June 07, 2016 at 09:34 AM

    I am trying to setup this ap but it does not work at all. In fact I cannot even log in. It just goes back to the login page and I cannot setup anything.

  • Profile Image
    Answered on June 07, 2016 at 10:43 AM

    I have just checked our Jot2Tweet app with my standard and my EU Jotform accounts, and the app seems to be working fine.

    1. It first prompted for authorization:

    2. Upon authorizing access, it prompted to select which form to connect:

    3. Upon selecting which form I wanted to connect, it would be displayed in the app, and we need to click on the "Connect Now" button in order to authorize Jot2Tweet app to access the desired Twitter account:

    The app seems to be working fine so far, and I am not sure if I understand in which of these steps you were unable to login. Were you having troubles logging into your Jotform account, or into Twitter?

    When setting up this app, I would highly recommend that you first log into both your Jotform, and your Twitter accounts, in different tabs of the same browser.

    After logging into both accounts, please use the direct link to our app, and then try setting up the app from there:

    If the issue persists, could you please take a screenshot of where it is failing, so we can better understand what may be causing it? You can then add images to your post on our support forum by following these instructions:

    Please let us know how it goes.

  • Profile Image
    Answered on June 07, 2016 at 01:45 PM
    Thanks for getting back. I have tried opening my Twitter account and Jot Form, and then trying, but it still will not allow me to continue. All I get is to tell me to log in. So, I do, but it just goes back to the login again. Please see screen shot attached.
  • Profile Image
    Answered on June 07, 2016 at 03:17 PM

    Unfortunately, the images attached replying to the email response cannot be posted to the forum thread. You may share the screenshot of the error by opening the forum thread URL directly.

    I have tried connecting one of the forms to my twitter account using Jot2Tweet app and see that the App is working without any issue.

    Once the form is submitted, I am able to see the tweet in my Twitter account.

    Could you try closing all the instances of the browser and open a fresh instance of the browser to login to your Jotform account to see if that works?

    Let us know if the issue still persists. We will be happy to assist. 

  • Profile Image
    Answered on June 07, 2016 at 05:44 PM

    If nothing happens when you log in on that form, I would suggest to login at then go back to the twitter app so you will not be prompted with the login form again. You should see the auth page directly.

    Once you see this window, you must allow the app so you can proceed on selecting a form to be used on the app.

    I would also suggest to try it using a different browser like Chrome or Safari since you are on Mac base from the browser agent lookup here on the forum.

    If this doesn't help, let us know so we can further assist you.

  • Profile Image
    Answered on June 07, 2016 at 10:13 PM

    Can you please try to re-integrate? 

    I also tried it on OSx - Firefox and it worked for me.

    I also could not reproduce the new issue either. I suggest to please try it again. Make sure to update your browser if necessary.

  • Profile Image
    Answered on June 07, 2016 at 10:16 PM

    You can also try to remove the Jotform 2 Twitter app in your API page Then go to the tweet app again and re-integrate your form.

  • Profile Image
    Answered on June 08, 2016 at 06:14 AM


    Since we cannot replicate the issue on a basic method of integration, perhaps you can provide us more information on which fields of your form you're trying to integrate with on twitter? That may shed some light to the issue at hand.

    We'll be looking forward to your response.


  • Profile Image
    Answered on June 08, 2016 at 10:00 AM

    Thank you for providing more details. It might be related to having a sub-label for a full name. Could you please delete the sub-labels in your field for testing?

    After that, We would appreciate it if you could try to re-integrate Jot2tweet Application. If this does not resolve the issue, please let us know and we will be glad to take another look.

  • Profile Image
    Answered on June 08, 2016 at 11:36 AM

    Thanks for your reply, Danny.

    Whenever you need our assistance again with any of your forms, feel free to let us know. We'd be happy to help you.