What is JotForm?
JotForm is a free online form builder which helps you create online forms without writing a single line of code. No sign-up required.

At JotForm, we want to make sure that you’re getting the online form builder help that you need. Our friendly customer support team is available 24/7.

We believe that if one user has a question, there could be more users who may have the same question. This is why many of our support forum threads are public and available to be searched and viewed. If you’d like help immediately, feel free to search for a similar question, or submit your question or concern.


  • Profile Image

    Cannot Submit Form in Internet Explorer 8 -

    Asked by nicostan on March 19, 2012 at 11:59 AM

    This is the form I am working on:

    https://secure.jotform.us/nicostan/prismeforum

     

    I am testing the form using the direct link (not embedded in another site).  

    I am running Windows XP.  I have successfully submitted the form in the following browsers:

    Chrome 17

    Firefox 11

    Safari 5.1.4

     

    I am unable to submit a form in Internet Explorer 8.  When I click the submit button, I get the following error: Internet Explorer cannot display the webpage.  This problem can be caused by a variety of issues, including:

    Internet connectivity has been lost. The website is temporarily unavailable. The Domain Name Server (DNS) is not reachable. The Domain Name Server (DNS) does not have a listing for the website's domain. There might be a typing error in the address. If this is an HTTPS (secure) address, click Tools, click Internet Options, click Advanced, and check to be sure the SSL and TLS protocols are enabled under the security section.

     

    I have tried modifying the thank you page, changing the security settings of IE, changing the address from secure.jotform to www.jotform.

     

    Can you recreate this issue and diagnose the problem?

     

    Thank you.

    Page URL:
    https://secure.jotform.us/nicostan/prismeforum

    Screenshot
  • Profile Image

    Answered by jcm0731 on March 19, 2012 at 12:10 PM

    Hi,

    I went ahead and submitted a test on your form:

    https://secure.jotform.us/nicostan/prismeforum

    on IE8 and everything works fine on my end. Can you please try to clear your browsers cache.

  • Profile Image

    Answered by pinoytech on March 19, 2012 at 12:13 PM

    Hi,

    Upon testing your form using IE8 its working properly and I was able to send also. I suggest delete browsing cache and cookie then re-embed your form in to your website page. And if this issue still presist, you can contact us anytime so we can further assist you and investigate the said issue.

    Thank you!

  • Profile Image

    Answered by nicostan on March 19, 2012 at 12:14 PM

    Hi,

    OK - cache cleared.  Same results.  Still cannot submit form.

  • Profile Image

    Answered by nicostan on March 19, 2012 at 12:15 PM

    re pinoytech - the form is not embeded.  I am testing it directly on your site: https://secure.jotform.us/nicostan/prismeforum

  • Profile Image

    Answered by nicostan on March 19, 2012 at 12:24 PM

    After several attempts, it finally displayed something other than the connection issue error:

    "There is a problem with this website's security certificate. 

    The security certificate presented by this website was issued for a different website's address.

    Security certificate problems may indicate an attempt to fool you or intercept any data you send to the server. "

     

    When I continued to the page, I saw this Jotform Error:

    Error

    Form ID did not match  

     

    However, I was only able to get this result 1 time.  All other times I click submit, I still get the "Internet Explorer cannot display page" error.

  • Profile Image
    JotForm Support

    Answered by idarktech on March 19, 2012 at 01:02 PM

    @Nicostan,

    I was able to reproduce the problem. I will now submit this issue to our developers to go with the further investigation. We'll keep you posted if any updates are available. 

    Apologies for the inconveniences. Thanks.

  • Profile Image
    Chief Technology Officer

    Answered by eee on March 21, 2012 at 05:48 AM

    Hi,

    Problem is fixed now,

    Kindest Regards,

    Ertugrul.

  • Profile Image

    Answered by guest_30104833360038 on January 11, 2013 at 11:28 AM

    @eee: Can you explain what the fix was? I am not a JotForm user but we are seeing similar behaviors in IE for one of our web apps.  Please let me know, thanks!

    ~~James

  • Profile Image

    Answered by guest_30104833360038 on January 11, 2013 at 11:30 AM

    @eee: Can you explain what the fix was? I am not a JotForm user but we are seeing similar behaviors in IE for one of our web apps.  Please let me know, thanks!

    ~~James

  • Profile Image

    Answered by guest_30104833360038 on January 11, 2013 at 11:31 AM

    ...no idea why it's still saying I'm a guest rather than a logged in user.  If you can answer this, please email me at:

    james.m.greene -AT- gmail    (you know the rest)

  • Profile Image
    JotForm Support

    Answered by NeilVicente on January 11, 2013 at 11:39 AM

    James,

    I am afraid we cannot help you with your problem. The fix Erturgrul was talking about is an internal system fix, and will not work with forms not created with JotForm. Sorry about that.

  • Profile Image

    Answered by JamesMGreene on January 11, 2013 at 01:38 PM

    Ah, bummer.  Nothing generic like "had to tweak a web server setting" or "had to strip a trailing CrLf", huh?

  • Profile Image
    JotForm Support

    Answered by Mike_T on January 11, 2013 at 02:44 PM

    There is a chance that Erturgrul will reply once he is available. Thank you for asking :)