Date/Time fields having data shown as "undefined" after editing submissions

  • Profile Image
    acase
    Asked on June 09, 2016 at 09:47 AM

    The "Hauling" Dynamic drop down is causing to the form to not be able to submit once the form is edited. Please help.

  • Profile Image
    david
    Answered on June 09, 2016 at 11:51 AM

    I cloned your form to test it and I was able to submit the form with both dynamic dropdown fields.  I was then able to edit that submission and re-submit the form.  Are you still unable to submit the form or edit submissions or your end?  Let us know and we will be happy to have another look.

  • Profile Image
    acase
    Answered on June 09, 2016 at 11:53 AM

    Look at W26551, when you try to edit it blanks out the work date the time and time out and won't submit

  • Profile Image
    acase
    Answered on June 09, 2016 at 12:18 PM

    When editing fields are coming up blank and it is deleting information, example employee 2 i had to add back.

  • Profile Image
    david
    Answered on June 09, 2016 at 01:51 PM

    I am able to reproduce this on my end.  Id does not seem to be related to the dynamic dropdown fields.  When I edit the submission, the first field for all date/time fields is having the data removed.

    I am still trying to figure out what specifically is causing the first entry for those fields to be removed.  I will update this thread as soon as I have.

  • Profile Image
    david
    Answered on June 09, 2016 at 02:31 PM

    Though I am still not quite sure what is causing this to happen, I was able to get a copy of your form down to only time fields.  These fields, when editing the submission data, have the hour field reverting to "Undefined" after submitting the edit:

    I will forward this to our developers to have a closer look.  We will let you know as soon as we have any further information.  For the time being, I would recommend not editing those submissions.

  • Profile Image
    acase
    Answered on June 16, 2016 at 02:25 PM

    The Hauling Dynamic drop down is not showing up completely on on mobile devices.  When filling out the form on phone some of the drop downs (time, job type, job status) you have to select it twice to get it to go in.

  • Profile Image
    acase
    Answered on June 16, 2016 at 02:28 PM

    Also please try to edit W26945, so get the edit to go through you have to hit submit redo the hauling drop down, submit and and then edit again b/c the hauling drop down will be blank.

  • Profile Image
    david
    Answered on June 16, 2016 at 03:46 PM

    Newly edited submissions should now show the correct data and no longer remove any data.  As for the mobile issue, if you wouldn't mind creating a new thread, we will be happy to have a look.

  • Profile Image
    Foltved
    Answered on September 17, 2016 at 05:14 PM

    Same issue here.

    When trying to edit, the parent data stays intact, but the the "child data" is gone, and even when inputting new child data, it wont let me re-submit the form.

     

    formID = 62436287991367

  • Profile Image
    Foltved
    Answered on September 17, 2016 at 05:19 PM

    I temporarly fixed, by removing the "required field" status for the dynamic dropdown, but in the long run, the field needs to be required

  • Profile Image
    jonathan
    Answered on September 17, 2016 at 10:21 PM

    @Foltved

    We will resolve your issue on your own thread here https://www.jotform.com/answers/935083