Enable / Require Field Condition: Required fields were sent blank for some submissions.

  • Profile Image
    corrine1968
    Asked on June 14, 2016 at 02:23 PM
    It also looks like a bunch of submissions this morning that had required fields came in without the info
  • Profile Image
    Kevin_G
    Answered on June 14, 2016 at 02:46 PM

    I have checked your form and I can see you have a condition that makes all other fields required, the field is "Attendance" and when it is answered with "I will attend the meeting" all other fields should be required, but in your submissions I found that some data is missing. 

    I will report this issue to our second level, since although the condition is met seems like required fields were by-passed. 

    We will notify you via this thread when this is resolved. 

  • Profile Image
    corrine1968
    Answered on June 14, 2016 at 02:52 PM

    Please, as this is vital information. They all seemed to happen within a 3 minute time frame...

     

  • Profile Image
    BJoanna
    Answered on June 14, 2016 at 04:43 PM

    My colleague reported this issue to our developers. When this issue is resolved we will inform you via this thread. 

  • Profile Image
    corrine1968
    Answered on June 15, 2016 at 08:19 AM

    THIS IS STILL HAPPENING!  They all seem to have come from the same two IP addresses. Is this a firewall issue? Please help asap we are losing registration data. I dont think a new form would help this issue. 

  • Profile Image
    Welvin
    Answered on June 15, 2016 at 09:44 AM

    This has been assigned to our developer with a high priority. You should receive a reply through this thread once they find the cause and fixed it. 

    While waiting, you may consider the following workaround/changes that I think should resolve your problem:

    1. Delete your conditional logic 2 and 3.

    2. Add and utilize show/hide conditional logic for the fields:

    Here's a cloned version of your form showing these changes: https://form.jotform.com/61664077910963

     

    Note:

    When requiring a field through condition, make sure that it's not required by default in the form builder. The same when unrequiring, the field should be required in the form builder. 

  • Profile Image
    Welvin
    Answered on June 15, 2016 at 09:45 AM

    I forgot to add, if the form is embedded, we recommend using our iframe method: https://www.jotform.com/help/148-Getting-the-Form-iFrame-Code. Sometimes, the default embed option will cause a conflict in a website causing users to submit the form without the required fields, the iframe should fix it.

  • Profile Image
    corrine1968
    Answered on June 15, 2016 at 10:20 AM

    I will try that. My question is, why have these conditions if they won't work and have to reverse the logic? That shouldn't matter..  just curious, I have made the changes you suggested. This form is not embedded anywhere... 

  • Profile Image
    Kevin_G
    Answered on June 15, 2016 at 11:28 AM

    Yes, you're right this is why this has been escalated to our second level since conditions worked before, the workaround suggested above should help you in the meantime, but this will be checked and resolved. 

  • Profile Image
    corrine1968
    Answered on June 15, 2016 at 11:43 AM

    My required name field is still not capturing data. Check my submissions, and i used the updates you suggested...

     

    Never mind, my bad, I forgot to enable that field.  I had to manually enter it on the row though, as the edit function did not update it to the sheet...

  • Profile Image
    KadeJM
    Answered on June 15, 2016 at 01:00 PM

    No problem and we're glad you were able to get the workaround working for the time being and we will notify you here as soon as the actual issue is resolved.