What is JotForm?
JotForm is a free online form builder which helps you create online forms without writing a single line of code. No sign-up required.

At JotForm, we want to make sure that you’re getting the online form builder help that you need. Our friendly customer support team is available 24/7.

We believe that if one user has a question, there could be more users who may have the same question. This is why many of our support forum threads are public and available to be searched and viewed. If you’d like help immediately, feel free to search for a similar question, or submit your question or concern.


  • Profile Image

    FTP not working with large files, Showing incomplete values when submitting the form.

    Asked by tricolorlab on June 16, 2016 at 10:46 AM

    We've had customers trying to send us files and the FTP form is NOT working.
    they receive a message:

    Incomplete Values

    Select file(s) is required

    Please go back and fix the problem

    i've edited, re-saved the form grabbed the new embed code for my site's iframe i tried to test it by uploading an image and received the same message.

    the file is 306MB file limit is set to 2GB, only 124MB of the file ended up on my FTP server.

    Page URL:
    http://tricolorlab.artstorefronts.com/ftp-upload

    Screenshot
    FTP ftp not working problem message site
  • Profile Image
    JotForm Support

    Answered by Kevin_G on June 16, 2016 at 12:34 PM

    I have tested your form and I was able to submit the uploaded file, but I have tested with a small file: 

    This seems to be related to the file size you are trying to upload, I would suggest you to check your FTP server and verify if there is a limit in the max size of an uploaded file, once you have verified then test the form again, please try removing the FTP credentials from the form settings and add them once again. 

    If after doing this the issue is still there, please let us know, we will be glad to assist you. 

  • Profile Image

    Answered by tricolorlab on June 16, 2016 at 04:45 PM
    the FTP server is fine, no upload limit, we use it all the time to
    receive large files from actual FTP clients like Fetch, etc...
    i've cleared out the FTP server info a re-entered it..... i don't like
    that your software doesn't put the files in the folder i specify, the
    FTP user has a home directory, that's where the files should go, but
    your software won't allow me to use / as the save directory, it was
    /something and then it goes and creates /something/FTP Upload
    which is a hassle
    i've tried uploading a file, sent to our ftp server using an ftp client
    originally, via the form, the first time it failed (peach colored box
    with the word "Failed" in it" i am trying to send it again, this file is
    395,903,113 bytes
    the transfer gets to 100% and then the box pops up saying "Failed"
    there was a limit on free accounts for file size, we were told that if
    we paid a subscription fee the size limit would be removed.
    if we can't receive large files easily from our customers, then your
    service is useless to us.
    ...
  • Profile Image
    JotForm Support

    Answered by BDAVID on June 16, 2016 at 06:36 PM

    What is the file type? Make sure is available in the allowed file types: https://www.jotform.com/help/29-Which-file-types-are-allowed-for-the-upload-field

  • Profile Image

    Answered by tricolorlab on June 17, 2016 at 09:45 AM
    trying to send a .tif file
    ...
  • Profile Image
    JotForm Support

    Answered by KadeJM on June 17, 2016 at 11:01 AM

    Thank you for the additional information about the file type.

    I checked and I can confirm that you've set it to allow that type of file.

     

    Have you tried making the file size a bit larger to see if that makes any difference such as above 400+ bytes?

  • Profile Image

    Answered by tricolorlab on June 21, 2016 at 09:45 AM
    I am testing with a large Tif file, the file was sent using an FTP
    client to the same server/account that the form is set to send to. so i
    know it isn't the server or user account settings.
    ...
  • Profile Image
    JotForm Support

    Answered by KadeJM on June 21, 2016 at 10:33 AM

    Would it be possible for you to send us a copy of this large tif file you are testing with it?

    This way we can try to troubleshoot this problem a bit more for you.

    If so you can use our image insertion tool to share it here or alternatively just email it to us as an attachment to support@jotform.com with a reference link to this thread.

  • Profile Image

    Answered by tricolorlab on June 27, 2016 at 09:45 AM
    Hey,
    we're still waiting to find out why the service we're paying you for
    isn't working.
    ...
  • Profile Image
    JotForm Support

    Answered by Kevin_G on June 27, 2016 at 10:56 AM

    I have tested your form and I was able to replicate the same issue, I tested with an image with about 5 MB size and got the same message, tried with a file with 1 MB size and it was successfully sent.

    I tested with the embedded form in your web page and the direct link to the form as well, with both versions I got the same error when tested with the large file. 

    Although I have cloned your form, integrated with an FTP server and I was unable to replicate the issue, I will escalate it to our second level so our developers will take a look into the issue and you will be notified via this thread when this is resolved. 

  • Profile Image

    Answered by tricolorlab on August 23, 2016 at 09:20 AM

    It's been two months, still no resolution, this service is useless, we've switched to Hightail and want to cancel our account and receive a refund....
  • Profile Image
    JotForm Support

    Answered by Chriistian on August 23, 2016 at 10:14 AM

    Hi tricolorlab,

    We understand your frustration and we apologize for the inconvenience. 

    We are sad to hear that you have switched to another service. Nevertheless, I have followed up with our developers about the issue.

    Regarding your cancel and refund request, I have moved it to a separate thread. We will respond to you there.