What is JotForm?
JotForm is a free online form builder which helps you create online forms without writing a single line of code. No sign-up required.

At JotForm, we want to make sure that you’re getting the online form builder help that you need. Our friendly customer support team is available 24/7.

We believe that if one user has a question, there could be more users who may have the same question. This is why many of our support forum threads are public and available to be searched and viewed. If you’d like help immediately, feel free to search for a similar question, or submit your question or concern.


  • Profile Image

    Fields in submission report is always resetting.

    Asked by vasupport on June 20, 2016 at 02:27 AM

    Hi Team,

    Custom fields are not showing properly in PDF report.

    I checked the fields that I want to show in every submission and set its condition to apply all the time. However, it is always resetting to all fields.

    Hope for your quick response.

     

    Regards,

    Gab

    submission report in checked all and not showing properly
  • Profile Image
    JotForm Support

    Answered by Chriistian on June 20, 2016 at 03:12 AM

    I unchecked some of the fields on the submissions page and downloaded the PDF of the submission. It appears that the fields that I unchecked are not displayed on the field. I cannot seem to replicate the issue that you have encountered.

    Can you please try clearing the form cache and your browser cache then create a PDF form again? If the issue still persists, please let us know.

  • Profile Image

    Answered by vasupport on June 20, 2016 at 03:38 AM

    Hi Christian,

    This is what happened:

    1. I unchecked the fields on the submission page

    2. I accessed "My Forms" link (just to leave the submission page web page and do nothing at all with my forms)

    3. Then, I came back to the submission page to see the settings and found that all fields are checked again

     

    I tried clearing the browser cache and it went back to normal. I guess the previous stored cache prevented me to save the settings on my submission page.

    So, what can we do to prevent this from happening again?

     

    Regards,

    Gab

  • Profile Image
    JotForm Support

    Answered by Chriistian on June 20, 2016 at 04:08 AM

    I checked the Submissions page of the form in your account it seems to be working fine.

     

    As per further checking, it seems that the fields checked is not saved when you do not close the field settings. Please ensure to close the field settings so the changes will be saved before reloading the page. You can check the demo below:

  • Profile Image

    Answered by vasupport on June 20, 2016 at 04:18 AM

    Thank you Christian! :)

  • Profile Image

    Answered by vasupport on June 24, 2016 at 01:07 AM

    Hi Christian,

     

    UPDATE: The submission page field is resetting to all when a new submission was arrived.

     

    Regards,

     

     

    Gab

  • Profile Image
    JotForm Support

    Answered by Chriistian on June 24, 2016 at 01:40 AM

    I checked the submissions on your form and it seems that the fields did not reset at this time. Some of the fields are currently unchecked. I assume you have unchecked these fields again? 

    I cloned your form and did some tests. It appears that the submission page field doesn't reset when there is a new submission.

    Does this issue occur in only this form? https://form.jotform.me/61583616846465. May we send a submission to your form so we can test the issue further? I will wait for your confirmation. 

     

  • Profile Image

    Answered by vasupport on June 24, 2016 at 02:04 AM

    Yes, I unchecked them before updating  this ticket. 

    OK, you can send a test submission to my form. I set some conditions for the E-mail address and PIN code, shall I provide you a new log-in credentials? Or, just use the gabriel.marcellana@gmail.com hide/unhide condition content.

  • Profile Image
    JotForm Support

    Answered by Chriistian on June 24, 2016 at 02:52 AM

    I have used the gabriel.marcellana@gmail.com and sent a test submission as Jotform Support. Unfortunately I cannot replicate the issue on my end. I checked the submission page before and after I submitted. The fields checked did not reset after I received the submission. Please see the screenshot below.

    Can you please check on your end to confirm if the issue still persists? I will wait for your response.