Cannot see the "Submit" button when using Google Chrome

  • Profile Image
    ebarfield
    Asked on March 22, 2012 at 11:49 AM

    A customer just sent us an email saying he attempted to fill out our "Contact Us" form on our website using Chrome. The "Submit" button is not showning. (see screenshot)

    What do I need to do to get this to appear?

  • Profile Image
    ItalyTech
    Answered on March 22, 2012 at 11:55 AM

    Hi, is your form id 11584854284 ?

     

    By the way, if your form ID is 11584854284 please try to re-embed it because I've applied a change.

    Thanks.

    Alessandro

  • Profile Image
    ebarfield
    Answered on March 22, 2012 at 12:05 PM

    I did with not change - 

  • Profile Image
    ebarfield
    Answered on March 22, 2012 at 12:09 PM

    Works on Mac Chrome - not on PC Chrome

  • Profile Image
    ItalyTech
    Answered on March 22, 2012 at 12:10 PM

    ok but please tell us your form id. It's 11584854284 ? 

    What embed method do you use ?


  • Profile Image
    pinoytech
    Answered on March 22, 2012 at 12:13 PM

    Have you tried already the iFrame method? If no, please give a try.

  • Profile Image
    ebarfield
    Answered on March 22, 2012 at 12:14 PM

    Yes the form ID is correct.

     

    http://www.jotform.com/form/11584854284

     

    I have tried 2 - <embed> & <source>

  • Profile Image
    ebarfield
    Answered on March 22, 2012 at 12:17 PM

    iFrame works better - I can now see the submit button (although part of the button is cut off)

  • Profile Image
    ebarfield
    Answered on March 22, 2012 at 12:20 PM

    Thank you - I think the other issue is a problem with my web page.

  • Profile Image
    pinoytech
    Answered on March 22, 2012 at 12:30 PM

    Glad to know that your form is working now properly.

    Thank you for using JotForm!