What is JotForm?
JotForm is a free online form builder which helps you create online forms without writing a single line of code. No sign-up required.

At JotForm, we want to make sure that you’re getting the online form builder help that you need. Our friendly customer support team is available 24/7.

We believe that if one user has a question, there could be more users who may have the same question. This is why many of our support forum threads are public and available to be searched and viewed. If you’d like help immediately, feel free to search for a similar question, or submit your question or concern.


  • Profile Image

    SalesForce Integration: Submissions data is not forwarded to SalesForce

    Asked by DrivePayments on June 24, 2016 at 11:46 PM

    Hi,

     

    I'm trying to get very basic information to pass into Salesforce and don't know what I'm doing wrong. Right now the only field I'm trying to map over is "name" just so I can get it working. Username/Password/Token are all up to date and everything appears to process fine but nothing shows up in my Salesforce. Thoughts?

    Page URL:
    https://submit.jotform.us/submit/61605050749151/

  • Profile Image
    JotForm Support

    Answered by EltonCris on June 25, 2016 at 02:57 AM

    I see that you have mapped more fields now not just the full name field. May we know if it's now working?

    If not, may I suggest to re-integrate your form to SalesForce and check it again.

    If you continue to encounter the same issue, please let us know so we can check this in depth.

  • Profile Image

    Answered by DrivePayments on June 25, 2016 at 10:52 PM

    Hi there,

    I actually deleted those fields and just came "name" on there but it appears that the JF integration doesn't actually delete them when you do that (i've tested this a couple times). The only fix is to completely remove the integration, do the authentication again and then re-map your fields.

    I have done this and only have "name" that I'm trying to pass through to my "Accounts" and it's not working. Do I have to turn something on inside of Salesforce?

    Thanks for your help,

  • Profile Image

    Answered by DrivePayments on June 25, 2016 at 11:51 PM

    We are using the Salesforce Nonprofit Starter Pack just as an FYI

  • Profile Image
    JotForm Support

    Answered by EltonCris on June 26, 2016 at 01:40 AM

    Thanks for your reply. We will check it and get back to you with updates.

    Stay tuned!

  • Profile Image
    JotForm Support

    Answered by EltonCris on June 26, 2016 at 02:13 AM

    I think it won't matter which account type you're using for as long as the integration is active and completed.

    So I went ahead and cloned your form and made a test submission to it, it is working normally as expected.

    Screencast:

    Please try the following and see if this makes a difference.

    1. Remove SalesForce integration in your form

    2. Create a new SalesForce security token

    3. Re-integrate your form to SalesForce and use the new security token

    4. Save your form and make a test submission

    5. Check the data in your SalesForce - filtered with Recently Created

    Let us know if the issue still persists after that. Thanks!