Stack Overflow in IE using the straight HTML embed?

  • Profile Image
    jonschr
    Asked on March 26, 2012 at 01:18 PM

    I am working on a site and -- while I knew that the script embeds of Jotforms had the potential to cause stack overflow errors -- I wasn't aware that a straight HTML embed of a form would do the same thing.

    I can't switch to the iframe solution for this particular site, as I'm coding it with media queries and need elements of the form to resize dynamically based on the size of the browser window.

    The site is http://client.redfishbluefishmedia.com.

    Is there anything I can do to easily resolve this? I understand the technical challenges you guys are facing, but I think it's a new thing that even the HTML embeds don't work correctly.

  • Profile Image
    jonathan
    Answered on March 26, 2012 at 04:51 PM

    Hi jonschr,

    May I know which version of IE you encountered the stack overflow issue? If you can, may I also request if you could provide us a screen capture when the stack overflow happen.
    I tried the URL http://client.redfishbluefishmedia.com/ on IE 7,8,9 versions and I was able to browse it. Since my OS is Windows 7, I was also able to view by default in IE9 without any error. Below are also the screens when I tested on different IE version.

    Thanks.

     

    IE7

     

    IE8

     

    IE9

  • Profile Image
    jonschr
    Answered on March 26, 2012 at 05:08 PM

    Interesting. 

    I saw the errors happening while testing in IE8 using VMWare Fusion (I'm on a mac), after refresing the home page.

     

    Screenshot below:

  • Profile Image
    jonathan
    Answered on March 26, 2012 at 05:21 PM

    Hi,

    Unfortunately, I don't have vmware so I may be limited in duplicating your scenario. But I do have the Windows Virtual PC with Windows server 2003 running IE 8. I will try to duplicate your step as much as I can. Please wait a while as I will boot the virtual machine and test the URL there.

  • Profile Image
    jonathan
    Answered on March 26, 2012 at 05:56 PM

    Hi,

    I was also able to reproduce the stack overflow error in the virtual environment.
    Similarly though, there is a detailed suggestion provided my colleague fxr on this thread https://www.jotform.com/answers/82671-I-am-getting-Stack-overflow-error-on-line-225- which I think provided an alternative fix to the issue. You may want to check it out first before we dig further to find resolution.

    Hope this helps. Just post back if you require further assistance.

    Thanks.