What is JotForm?
JotForm is a free online form builder which helps you create online forms without writing a single line of code. No sign-up required.

At JotForm, we want to make sure that you’re getting the online form builder help that you need. Our friendly customer support team is available 24/7.

We believe that if one user has a question, there could be more users who may have the same question. This is why many of our support forum threads are public and available to be searched and viewed. If you’d like help immediately, feel free to search for a similar question, or submit your question or concern.


  • Profile Image

    Unable to submit two of the same form

    Asked by WPRanch on July 12, 2016 at 03:42 PM

    We have complaints from parents that are trying to register multiple children up for camp can only submit one form one time.  It fails when they attempt to sign up a second child using the same form link.  I'm guessing it has something to do with caching but is there anything we can do or tell our parents to do differently?  Again the problem is not consistent. It works for some parents and not for others.

    Page URL:
    https://form.jotform.com/60065433646151

    same form same unable to form link problem caching
  • Profile Image
    JotForm Support

    Answered by BDAVID on July 12, 2016 at 05:36 PM

    Your form does not have a limitation, so the same person can submit the form as many times he wants.

    Do they get any error message when submitting for the second time? If yes, please let us know, you could share a screenshot if you wan to: https://www.jotform.com/answers/277033-How-to-add-screenshots-images-to-questions-to-the-support-forum 

  • Profile Image

    Answered by WPRanch on July 25, 2016 at 02:32 PM

     

    Here is what I experienced, while trying to register two children, back-to-back.

    (1) On the first attempt and following the successful registration & payment for one daughter, I filled out the forms for my second daughter (much of the information was auto-filled from the first registration), but when I tried to submit WITH payment,  and after being routed to the PayPal page and choosing to use a Credit Card, I was given a message that stated that my card could not be used for the transaction.  Same card had been used for the previous transaction, successfully.

    (2) Contacted Andee and followed her suggestion to re-try the following day.  I did so, with the exact same result.

    (3) Contacted the Credit Card company, thinking there may be a problem with my card, and to inform them that a duplicate payment to Little Sisters/White Pines was appropriate.  No problem indicated and payment for the first registration was confirmed.

    (4) Tried registering a few more times over several days, trying both with and without." payment.  Most times, the process would get "hung" at the final step when trying to submit the forms, indicating "please wait." Did not receive any indication that the process was complete, so ...

    (5) Contacted Andee to see if she had received anything at all.  By now, I was interested to see if the submission without payment had worked.  Nope!!  I gave her my credit card info to make the charge, manually.  She requested that I bring the paperwork to camp on Day 1.
    I was able to print the electronic forms.

    (6) Additional information --Registration (both successful and unsuccessful) were performed on a MacBook Air laptop, using Safari to access the forms, and using either remote home or hotel wi-fi, as we were traveling during all attempts.

    Lastly, I hope this information is helpful.  Although lengthy, I believe more is better in finding a solution!!

  • Profile Image
    JotForm Support

    Answered by BDAVID on July 25, 2016 at 04:01 PM

    I can see that you are using Sandbox mode, simply select your payment field, click on its gear icon, then on "Edit Properties", and disable the Sandbox mode:

    Let us know if you need more help.

  • Profile Image

    Answered by WPRanch on July 25, 2016 at 04:21 PM

    Please be advised, that is a test form that we do not have end users hitting.  This is the one that is being used and experiencing the issues stated:

     

    https://www.jotform.com//?formID=61385119163152

     

     

  • Profile Image
    JotForm Support

    Answered by Mike on July 25, 2016 at 07:10 PM

    The issue has been escalated to our developers via the next thread:

    https://www.jotform.com/answers/890114

    Thank you.