What is JotForm?
JotForm is a free online form builder which helps you create online forms without writing a single line of code. No sign-up required.

At JotForm, we want to make sure that you’re getting the online form builder help that you need. Our friendly customer support team is available 24/7.

We believe that if one user has a question, there could be more users who may have the same question. This is why many of our support forum threads are public and available to be searched and viewed. If you’d like help immediately, feel free to search for a similar question, or submit your question or concern.


  • Profile Image

    Inventory Widget -It only allow to select 0 quantity in the dropdown options.

    Asked by CarolTasseff on July 15, 2016 at 12:41 PM

    Hi, 

    Suddenly I'm having trouble with the inventory widgets that were working perfectly at first. Now when I preview the form and try to select my choices, all the inventory boxes are throwing up a warning saying I can only select 0 even though there's plenty of inventory left. I searched the problem on the forum and tried all the suggestions there but it is still not working.

    The last changes I made did involve the inventory widgets - If you look down into the Fees and Payments section, you will see that I am using Form Calculations to add up the fees associated with the numbers selected in all the Inventory widgets. Could these calculations be causing the problem? 

    Also, see the link below in the URL box..I've never seen the words "preview=true" on the end of a link before. Could that be a clue?

    I really want this form to work reliably! Thanks!

     

    Page URL:
    https://www.jotform.us/form/61945921589167?preview=true

    select inventory widget can using form form calculations problem calculations
  • Profile Image
    JotForm Support

    Answered by ashwin_d on July 15, 2016 at 01:19 PM

    Hello CarolTasseff,

    I'm sorry for the trouble caused to you.

    I did test your form and I am able to replicate the issue you are having. I am not sure what is causing this issue but the widget seems to work as expected in one of my own form.

    Let me do further test to figure out the cause of this issue. I will get back to you on this soon and if required, I will report it to our back end team.

    Thank you!