What is JotForm?
JotForm is a free online form builder which helps you create online forms without writing a single line of code. No sign-up required.

At JotForm, we want to make sure that you’re getting the online form builder help that you need. Our friendly customer support team is available 24/7.

We believe that if one user has a question, there could be more users who may have the same question. This is why many of our support forum threads are public and available to be searched and viewed. If you’d like help immediately, feel free to search for a similar question, or submit your question or concern.


  • Profile Image

    Issue with Zoho Intergration.

    Asked by matht on July 17, 2016 at 11:46 PM

    Hi,

     

    I have contacted Zoho also but they take a long time to respond, Ideally i'd like to get this fixed as soon as possible.

     

    Currently the form seems to be integrating correctly as the "auth token" is activate on my zoho account and is input into jotform but none of the form data is appearing within Zoho.

    Page URL:
    https://secure.jotform.co/matht/Raywhitebusinesssales

    zoho JotForm form data Activate
  • Profile Image
    JotForm Support

    Answered by Chriistian on July 18, 2016 at 04:12 AM

    I cloned your form and integrated it with my Zoho account. I am currently doing some tests to try and replicate your issue. I will let you know on this thread once I am done testing. Regards.

  • Profile Image
    JotForm Support

    Answered by Chriistian on July 18, 2016 at 04:33 AM

    I sent a couple of submissions on my test form and it seems that the data appeared successfully in my Zoho leads. Can you please remove the integration in your form and then re-integrate it with Zoho CRM again?

    You can also try using a different authentication token. Please follow this link to view your active authtokens https://accounts.zoho.com/u/h#sessions/userauthtoken. Make sure you are logged in to your zoho account. To generate new tokens, please follow this guide: https://www.zoho.com/crm/help/api/using-authentication-token.html.

    If the issue persists, please let us know.

  • Profile Image

    Answered by matht on July 18, 2016 at 06:20 PM

    Hi,

     

    I have tried reintergrating it and had the same issues.

     

    It worked when I didn't map all the fields into Zoho, Now that I've mapped all the fields it is having issues with not sending the data across.

    Is there any way to see which field may be causing the issues?

  • Profile Image

    Answered by matht on July 18, 2016 at 07:32 PM

    Just another note.

     

    It seems that when I stripped the form of all mapping it doesn't work again.

     

    Summary:

    - When in base integration(Name/Email/Company mapped) it worked.

    - When I mapped more of the fields it didn't work.

    - When I stripped the mapping and put it back to base form it doesn't work now.

    - Tried integrating the main form and a clone of the form, clone worked first time as above, once mapped it doesn't work.

     

     

     

  • Profile Image
    JotForm Support

    Answered by Chriistian on July 18, 2016 at 09:46 PM

    I made further tests based on your specification, but I am still unable to replicate the issue. 

    - I mapped the Name, Email, Company fields first. The data went through to my zoho leads successfully

    - Then I mapped more fields based on my leads. The data is still sent to Zoho.

    - I removed the mapping and mapped the base fields again. Data was sent successfully.

    Can you please send us a screenshot of the fields that you mapped on your end so we may check it further? To send a screenshot, please visit this thread: https://www.jotform.com/answers/884717 and follow this guide: How to add screenshots/images to questions to the support forum?

    I will wait for your reply.
    Regards.

  • Profile Image

    Answered by matht on July 18, 2016 at 09:53 PM

    Hi Christian,

     

    Please see below:

  • Profile Image
    JotForm Support

    Answered by Chriistian on July 18, 2016 at 11:22 PM

    Can you please tell us the data types of all the fields matched on your zoho leads? This will help us identify the cause of the issue.

    Please note that the field types on your zoho should also match with the type on your form. So number fields should be matched with number fields and text fields on zoho should be matched with text fields on the form.

    I will wait for your response. 

  • Profile Image

    Answered by matht on July 19, 2016 at 01:14 AM

    Hi Christian,

     

    It seems my last response didnt come through.

     

    Could someone please contact me via phone on these issues.

     

    There is lots of mucking around here and I need these issues fixed. Its possible my fault that im not understanding. But I would like these issues solved as soon as possible.

     

    Also re above question data types seem to be a non issue. The ones you mentioned above were just me testing to see if all fields needed to be mapped.

     

    Appreciate your help.

  • Profile Image
    JotForm Support

    Answered by Chriistian on July 19, 2016 at 02:10 AM

    Please allow me to inform you that there is currently no support over phone. The best way to reach us is through this Support forum or at support@jotform.com.

    I see that the fields mapped from the screenshot were your tests. However, can you please still provide us with the fields and their data type so we may narrow down the issue at hand? Thank you.