Authorize.Net: Sell Subscription payment type is getting Error on Transaction.

  • Profile Image
    kehillatisrael
    Asked on July 20, 2016 at 03:31 PM

    Randomly, after working fine for weeks, we are getting the following message when we try to register:

     

    Error on transaction

    The element 'subscription' in namespace 'AnetApi/xml/v1/schema/AnetApiSchema.xsd' has invalid child element 'payment' in namespace 'AnetApi/xml/v1/schema/AnetApiSchema.xsd'. List of possible elements expected: 'shipTo, profile' in namespace 'AnetApi/xml/v1/schema/AnetApiSchema.xsd'.

    Please go back and fix this

     

     

  • Profile Image
    Mike_G
    Answered on July 20, 2016 at 05:38 PM

    Apologies for any inconvenience. I have searched for the error over the internet and to my understanding it is because Authorize.net XML requests only work with the fields in a specific order. Base on  the error you're getting, it seems that "payment" is not under "subscription". 

    It seems that it has something to do with how the products are being named. I see that some of the products in your payment tool are having special characters with their names. 

    Since this is happening randomly, can you check on your end if there is a specific product that's causing this issue, please?

    We will wait for your response. Thank you.

  • Profile Image
    kehillatisrael
    Answered on July 21, 2016 at 01:19 PM

    I don't think this is the answer, because over 200 people have completed the form with no issue and then just yesterday, it became an issue.  

    The Authorize.net account is not the issue because we are getting payments through other forms (on the same account).  

     

    Other thoughts?

  • Profile Image
    Mike_G
    Answered on July 21, 2016 at 03:29 PM

    Thank you for the additional information. 

    After further testing, I was able to reproduce the issue you're having.

    It seems that the Payment Type - Sell Subscription is broken.

    I will forward this to our developers so they can take a look at it. You will be notified via this thread for updates if there are any.

    Thank you.

  • Profile Image
    kehillatisrael
    Answered on July 22, 2016 at 11:33 AM

    Thank you.

     

  • Profile Image
    NeilVicente
    Answered on August 03, 2016 at 08:18 AM

    Hi,

    We have resolved this issue more than a week ago. Please do inform us if you're still having problems.

    Best,