Automatically ticking question boxes

  • Profile Image
    Victorine
    Asked on July 21, 2016 at 07:06 AM

    Hello

     

    I have created a form with several tick answer boxes for Yes, No or N/A.

    If someone needs to tick all the Yes answers in one go, is there a way I can set this up?

     

    Thanks

    Bictorine

  • Profile Image
    Irshad
    Answered on July 21, 2016 at 09:27 AM

    I think the Select All widget can help with your requirement.

    http://widgets.jotform.com/widget/select_all

    Please give it a try and let us know if you need any further assistance. We will be happy to assist. 

    Thanks.

  • Profile Image
    Victorine
    Answered on July 21, 2016 at 10:34 AM

    Hi Irshad

     

    Thanks - it is fine for a question with one tick box but mine are questions with three tick boxes each, one for yes, one for No and one for N/A.

    Please advise.

    Victorine

  • Profile Image
    BJoanna
    Answered on July 21, 2016 at 11:52 AM

    I have inspected your form and I saw that you added Select All widget to your form like my colleague suggested. 

    It is also possible to check multiple check box fields options based on selected option of another check box field.

    This is possible to achieve with conditional logic "Update/Calculate field".

    Here is my demo form: https://form.jotform.com/62024476016954 

    I have set conditions to update check box fields (1,2,3 and 4) if option yes on my first field is selected. I had to set condition for each check box field. My conditions look like this. Make sure to set field value of your field to "A-Z".

    Feel free to clone and test my demo form. 

    Hope this will help. Let us know if you need further assistance. 

     

  • Profile Image
    Victorine
    Answered on July 22, 2016 at 06:03 AM

    Hi 

    Thanks.  I have done as you suggested and put in the conditions but when I tick 'Do want to check all 'Yes' options' nothing happens.

     

    https://eu.jotform.com//?formID=62013145151339

     

    Would you be able to have a look for me and let me know what I have done wrong?

    Thanks

    Victorine

     

  • Profile Image
    Irshad
    Answered on July 22, 2016 at 07:41 AM

    I am checking it, and will send you further updates very soon.

  • Profile Image
    Irshad
    Answered on July 22, 2016 at 08:32 AM

    I think you have missed to put this condition:

    Make sure to set field value of your field to "A-Z".

     

    But you do not need to worry, I have created all the correct conditions in my Clone form, so you can make the clone of my below Form, and you will get all the correct conditions.

    Please check the clone form below:

    https://form.jotform.com/62033327144951

    If you face any issue, or need further assistance, feel free to revert back.

    Thanks.

  • Profile Image
    Victorine
    Answered on July 22, 2016 at 11:18 AM

    Dear Irshad

    Thank you very much for your help and for sorting out my problem. I now know where I went wrong.

    Have a nice weekend.

    Kind regards

    Victorine

  • Profile Image
    BJoanna
    Answered on July 22, 2016 at 11:32 AM

    On behalf of my colleague, you are welcome.

    Feel free to contact us if you have any other questions.