What is JotForm?
JotForm is a free online form builder which helps you create online forms without writing a single line of code. No sign-up required.

At JotForm, we want to make sure that you’re getting the online form builder help that you need. Our friendly customer support team is available 24/7.

We believe that if one user has a question, there could be more users who may have the same question. This is why many of our support forum threads are public and available to be searched and viewed. If you’d like help immediately, feel free to search for a similar question, or submit your question or concern.


  • Profile Image

    Why my Google Spreadsheet integration is not working?

    Asked by Pais21 on July 31, 2016 at 12:33 PM
    sheet google google spreadsheet spreadsheet integration
  • Profile Image
    JotForm Support

    Answered by Nik_C on July 31, 2016 at 01:24 PM

    Thank you for contacting us.

    Can you please let us know what is the problem you have if you can give us more details?

    Thank you.

  • Profile Image

    Answered by Pais21 on July 31, 2016 at 01:30 PM

    Thank you for getting back to me. I've been trying to use the Google Spradsheet ingegration, but it will simply not work. I follow all the steps. Pluggins - Apps - Google Spreadsheet - Get App - Authenticate and then after I press allow on my Google account a blank browser window will show up with this:

     

    http://www.jotform.com/api/google/?code=4/r92X_VBd40n-DXl44_cuzSZ45z6YGHhcGYmXsOpsSAU#

     

    I tried in all Browsers, Edge, Internet Explorer, Google Chrome and Mozila Firefox. Can you please help

    Thanks and regards,

     

    Joana

  • Profile Image
    JotForm Support

    Answered by Nik_C on July 31, 2016 at 01:57 PM

    I just tried to integrate my form with Google Spreadsheet and it went just fine. Did you make sure you're logged in into your Google account and then after that you should allow JotForm to access your Google Spreadsheet?

    You can also try to clear your cache, but you already tried in different browsers.

    Also, I checked your integration and it led me to the page where it asks for permission to access that Google Spreadsheet file.

    So I'm not sure if it is working for you now.

    We'll wait for your response.

    Thank you!

  • Profile Image

    Answered by Pais21 on July 31, 2016 at 02:36 PM

    Unfortunatly it is till not working. I am a Database Developer, so I tried other options and they did not work too. I tried SQL integration and Report to Dropbox. This last one worked, but the file didn't show my form submissions, so in the end it didn't work too. the purpose of all this is to integrate the form submissions with a Database I did develop.

  • Profile Image
    JotForm Support

    Answered by Boris on July 31, 2016 at 03:11 PM

    I noticed you are from Portugal, which means that you are using our EU servers. I have tested the integration with both a standard (US) account, as well as my European (EU) account, and both of them were instantly forwarding submission data to the integrated folder.

    This was from my EU account forwarding to Google Spreadsheets:

    Similarly with Google Drive integration, it instantly created folders and PDF files in my integrated Google Drive folder:

    I have also tested with a direct clone of your form, and the cloned version was also able to be integrated:

    And submissions were correctly forwarding to the integrated sheet:

    From what we are seeing, the integrations seem to be working fine on our end. If you are still getting this issue, and it is appearing to you in different browsers, it could be a regional issue. Before we proceed, could you please open your browser console when this empty page appears, and copy/paste any errors you are seeing in the browser console?

    The following page will describe how to use the browser console on most operating systems and browsers:

    http://www.wickedlysmart.com/hfjsconsole/

    We look forward to your response. You can also take a screenshot of the issue you are seeing, and upload it directly when posting your reply on this support thread.

    The following guide explains how to attach images to your replies on our forum:

    https://www.jotform.com/answers/414264

  • Profile Image

    Answered by Pais21 on August 12, 2016 at 06:45 PM
    Hello, thank you so much fo all your Help. I continuo not being able to do this integration. Now A message shows up saying:
    Integration Up & Running!
    Your spreadsheet's link can be found here:
    https://docs.google.com/spreadsheet/ccc?key=1JVPmaZBPjSHbVYJ-pNkHx6FstB7SP2LwnKoDhuBX_KE
    But when I clic the file with my Google account, another message comes up saying:
    Googel Drive
    You need permission
    Want in? Ask the owner for access, or switch to an account with permission. Learn more
    You are signed in as pais21.appt21@gmail.com.
    I don’t know why I cant open the file, once I am signed in with the above account. I didn’t get any message asking to give permission on my Gmail. What should I do?
    What I realy need is some kind of integration with a Sharepont list, but I cant find that, so I am trying other integrations, like SQL, Export Report, etc. None of them work.
    Can somebody help me. I am an experienced user.
    Best Regards,
    Joana
    [cid:image009.jpg@01CDEDFA.5583A470]
    [cid:image002.jpg@01D1F4EE.BC9F10F0]
    T (+351) 914 511 340
    joana@joanavillasboas.com
    www.joanavillasboas.com
    Linkedin Profile
    ...
  • Profile Image

    Answered by victor on August 12, 2016 at 07:43 PM

    This error normally occurs when you are trying to view a spreadsheet that does not belong to you.

    I am assuming that you used an account that is not yours. Assuming that it belongs to your company or a supervisor. If this is the case, you would need to ask the owner of the google account and ask them to give you permission to view/edit the spreadsheet

    https://support.google.com/drive/answer/2494893?co=GENIE.Platform%3DDesktop&hl=en

     

  • Profile Image

    Answered by Pais21 on August 13, 2016 at 06:45 AM

    Good Morning Victor,

     

    I am the database developer, so the client gave me access to his Jotform account and google account. I have both account usernames and passwords to be able to do the integration my self. How can I know who the owner is? I am logged in as the owner! I dont know what else to do, I've been struggling with this for severall days now. I am desperate.

  • Profile Image
    JotForm Support

    Answered by Jan on August 13, 2016 at 11:19 AM

    I understand your frustration. It is possible that you are currently logged in to another Google account while you are authenticating the integration. 

    1. Please try to log-out all Google accounts in your browser and try it again. If you are using Google Chrome, it is possible that you are logged in to your Google account by default.
    2. Please trying clearing your browser cache.
    3. Try to check if it will work if you use another browser.
    4. Clone the form and re-integrate  the clone form to Google Sheets.

    On top of that, I will clear your form cache so that your forms will be refreshed from our servers.

    Hope that helps. Thank you.