Input table is not working on condition.

  • CarolTechHobby72
    Asked on November 8, 2023 at 12:41 PM

    My form has a yes or no question about whether an order was delivered. If they answer "Yes", I show an input table asking them to evaluate our delivery service - was the team courteous, tidy, on time, etc. If they answer "No" on any of those input fields, meaning the delivery service wasn't tidy or anything else, I show a long text box where they can describe what they didn't like about our delivery service. Both the Input field and the Long paragraph questions are set on always hidden.

    This is all working perfectly.

    Input table is not working on condition Screenshot 70

    The problem comes if they answer "yes" the order was delivered, and then they choose "No" on any of the input values and the long paragraph shows up and THEN change their answer to the first question to No the order was not delivered. The input table disappears, but the long paragraph question stays visible.

    Input table is not working on condition Screenshot 81

    Here is what I have tried so far after looking through support:

    First, I activated the "Clear on Being Hidden" setting. The input table IS clearing - but the long paragraph isn't disappearing as it should.

    Input table is not working on condition Screenshot 92Input table is not working on condition Screenshot 103

    Next, I changed the condition for showing the long paragraph to multiple conditions. I had hopes for this however now the long paragraph only shows up if they answer "Yes to was your order delivered and "No" to ALL the fields in the input table. Before the paragraph would appear if they only chose 1 No field.

    Input table is not working on condition Screenshot 114

    Input table is not working on condition Screenshot 125

    I know I can do it by adding a page with the delivery questions and skipping it if they answer that the order was not delivered. However, I'm trying to make this a very short, simple, one-step survey to encourage as much participation as possible.

    I know that most respondents will not change their mind and go back to answer No but some will. I want the form to be as professional as possible.

    I'd appreciate a helping hand!

  • Waqas JotForm Support
    Replied on November 8, 2023 at 1:40 PM

    Hi Carol,

    Thanks for reaching out to Jotform Support. I'm sorry you're having difficulties with this. Keep in mind that if you set a value to no, all the nos will display the paragraph. Because it is set as all. Check out my screencast below:

    Input table is not working on condition Screenshot 40

    Can you try to add this condition separately? Check out my screenshot below for the condition:

    Input table is not working on condition Screenshot 51

    Check out my screencast below for the results:

    Input table is not working on condition Screenshot 62

    You can check my clone form and you can clone it as well. Can you give it another try and let us know what happens? If you're still having the same issue, we'll do a more in-depth investigation and work on finding a solution.

    Give it a try and reach out again if you have any other questions.

  • CarolTechHobby72
    Replied on November 8, 2023 at 1:50 PM

    Yes, thanks, your suggestion is how I started out. I only tried the "ALL" condition when I got the problem I described at the beginning of my post. Once the long paragraph is made to appear, it will not disappear if the respondent changed the yes to no on the first question, even when the input table is hidden and cleared.

    Input table is not working on condition Screenshot 20

    That's where I need a little help.

  • Waqas JotForm Support
    Replied on November 8, 2023 at 2:16 PM

    Hi Carol,

    Thanks for getting back to us. Yes, you just need to add two conditions. I shared the wrong clone before, and I'm sorry for that. Check out my screenshots below for the conditions:

    Input table is not working on condition Screenshot 40Input table is not working on condition Screenshot 51

    Check out my screencast below for the results: Input table is not working on condition Screenshot 62

    You can check out my clone form here. Can you try it again and see how it goes? If you run into the same issue again, let us know, and we'll do some more testing to see what's going on. 

    Give it a try and reach out again if you have any other questions.

  • CarolTechHobby72
    Replied on November 8, 2023 at 2:30 PM

    I'm thankful for your help, but I'm looking for a way for the paragraph to DISAPPEAR under the scenario where the respondent changes the delivery answer to NO.

    Input table is not working on condition Screenshot 20

  • Waqas JotForm Support
    Replied on November 8, 2023 at 3:10 PM

    Hi Carol,

    Thanks for getting back to us. I'm sorry you're having difficulties with this. Yes, this is because of the first condition, which displays the field. I understand the issue, but I’ll need a bit of time to work out a solution. I’ll get back to you shortly.

    Thanks for your patience, we appreciate it.


  • CarolTechHobby72
    Replied on November 8, 2023 at 3:38 PM

    Thanks!

    Just to be clear, the first condition ONLY displays the input table field. It does NOT show the long paragraph. The long paragraph ONLY appears if there is a NO response in one of the table fields. This is as it should be. And it disappears if the person changes all the input fields back to YES. This is as it should be. BUT, once it appears bc the person has entered a NO, it will not disappear if the person goes back two questions and changes their "Yes" it was delivered to "No" it wasn't delivered.

    Condition 1: (This works perfectly)

    Input table is not working on condition Screenshot 40

    Condition 2: (This works perfectly)

    Input table is not working on condition Screenshot 51

    This next picture illustrates the problem. Let's say the person at first said the order was delivered. The input table popped up as expected. Then the person answered "no" on one of the fields, so the paragraph question popped up as expected. THEN, the person changed their mind and went back and answered that the order WASN'T delivered. The input table disappears as expected, but the paragraph question is still visible, even though I have turned on the "clear hidden fields" setting. My assumption is that once the input table is hidden bc the first answer changed to NO, it should be cleared (and it is working - it does clear), meaning that there is no longer a NO in the the input table. Then based on the second condition, the paragraph question should disappear bc there is no longer a No in any of the fields.

    There should be no delivery-related questions showing if the person goes back and changes their answer from Yes it was delivered to no it wasn't delivered.

    Input table is not working on condition Screenshot 62

    I hope I am expressing myself clearly. I appreciate your help!


  • Waqas JotForm Support
    Replied on November 8, 2023 at 6:09 PM

    Hi Carol,

    Thanks for getting back to us. When I tested your form, the same thing happened, so I created a ticket about it and escalated this to our Developers.

    Once we hear back from them, we’ll update this thread and let you know.


  • CarolTechHobby72
    Replied on November 22, 2023 at 10:27 AM

    Wondering whether there have been any developments on this issue.

    Thanks!

  • Ruan JotForm Support
    Replied on November 22, 2023 at 10:44 AM

    Hi Carol,

    Thanks for getting back to us. I understand that this is frustrating for you and that it is taking longer to solve than expected. We need just a bit more time to come up with a solution. We’ll get back to you as soon as we have one.

    We really appreciate your patience and understanding. 

  • Erwin Support Team Lead
    Replied on November 28, 2023 at 8:59 AM

    Hi Carol,

    Thanks for your patience. I have heard from the relevant team that this issue has been resolved. Can you check it again to see if your issue persists?

    You can see the demo form in the screencast below, the condition is working as expected.

    Input table is not working on condition Screenshot 20

    Give it a try and let us know how it goes.

  • CarolTechHobby72
    Replied on November 29, 2023 at 10:09 AM

    Yes, it is working now!

    Thank you for getting back to me with the solution!