What is JotForm?
JotForm is a free online form builder which helps you create online forms without writing a single line of code. No sign-up required.

At JotForm, we want to make sure that you’re getting the online form builder help that you need. Our friendly customer support team is available 24/7.

We believe that if one user has a question, there could be more users who may have the same question. This is why many of our support forum threads are public and available to be searched and viewed. If you’d like help immediately, feel free to search for a similar question, or submit your question or concern.


  • Profile Image

    Why are widgets not loading on my form?

    Asked by pguerra on August 01, 2016 at 05:21 PM

    Page URL:
    https://form.jotform.com/52443928433963

  • Profile Image
    JotForm Support

    Answered by Kevin_G on August 01, 2016 at 10:15 PM

    The ones that are not loading are widgets, seems like for some reason they are blocked on your end as I have tested the form on my end and widgets load fine, see my scree-cast below: 

    If the issue still persists, please share us a screenshot of the web console, that will help us to know if widgets are blocked for some reason, these keyboard shortcuts will help you to get the console on Chrome: 

    Mac: Command + Option + J

    Windows: Control + Shift + J 

    We will wait for your response. 

  • Profile Image

    Answered by pguerra on August 02, 2016 at 09:51 AM

    The problem still persists:

     

  • Profile Image
    JotForm Support

    Answered by Kevin_G on August 02, 2016 at 12:05 PM

    I can see the issue happens when you're checking the form in the Form Builder too, for some reason the resources that load the widgets are missing. 

    Could you please try on another computer? 

    If it works, please try checking if there is something blocking the resources, try disabling your antivirus and anything else that may be blocking this so we can know if this is the reason. 

    Also, is the issue on other forms? 

    Please try loading this form which has widgets on it: https://form.jotform.com/53555970106962 

    I will also escalate the issue to our second level so our developers will also investigate the issue. 

  • Profile Image

    Answered by pguerra on August 02, 2016 at 12:15 PM

    Kevin,

     

    I have tried on another computer, but the widgets doesn´t load either.

    The same issue on other form:

     

  • Profile Image
    JotForm Support

    Answered by Kiran on August 02, 2016 at 01:36 PM

    Thanks for checking. I'm also not able to replicate the issue and the widgets are loading fine at my end. I see that the issue is already forwarded to our backend team by our colleague. If there is any update in this regard, you'll be posted here.

    Could you also confirm that you have tried loading the form after disabling the anti-virus? You may also try using a different browser and let us know the results.

    Thanks!

     

  • Profile Image
    JotForm Support Manager

    Answered by Jeanette on August 02, 2016 at 05:55 PM

    403 error means that the request is understood, but it has been refused or access is not allowed. This code is used when requests are being denied due to update limits.

    Please clarify if you tried loading the form using other browsers such as Firefox, Safari, etc.

  • Profile Image

    Answered by pguerra on August 02, 2016 at 05:57 PM

    I am using Google Chrome.

  • Profile Image
    JotForm Support

    Answered by Kiran on August 02, 2016 at 09:07 PM

    Could you try accessing the form using a different browser viz., Firefox, Safari and after disabling anti-virus on your PC? I notice that there is an active Avast antivirus on your PC which may be blocking the widgets.

    Please check and let us know the results. We will wait for your response. Thank you! 

  • Profile Image

    Answered by pguerra on August 04, 2016 at 03:22 PM

    Hi,

    I tried on another PC.

    I tried accessing the form using Firefox after disabling anti-virus,

    ---

    Result: THE SAME ISSUE!

    I appreciate your help, I need to use these two forms as soon as possible.

    https://form.jotformz.com/50753804151652

    https://form.jotform.com/52443928433963

     

  • Profile Image
    JotForm Support

    Answered by Welvin on August 04, 2016 at 04:39 PM

    Can you check again? I have re-saved your widgets and form then cleared your forms cache. I hope these things helps.

  • Profile Image

    Answered by pguerra on August 04, 2016 at 05:44 PM

    The widgets don't load.

  • Profile Image
    JotForm Support

    Answered by Kiran on August 04, 2016 at 06:45 PM

    Could you try accessing the forms using your mobile connection or check on a different connection? We also request you to check with your ISP to check if something is blocking from their end. The guide Whitelisting-JotMails-IP-Addresses might help in whitelisting JotForm domains/IP addresses. 

    Also, please make sure that you have whitelisted the domain www.jotform.io since the widgets are loaded using this domain.

    Let us know if that helps.