What is JotForm?
JotForm is a free online form builder which helps you create online forms without writing a single line of code. No sign-up required.

At JotForm, we want to make sure that you’re getting the online form builder help that you need. Our friendly customer support team is available 24/7.

We believe that if one user has a question, there could be more users who may have the same question. This is why many of our support forum threads are public and available to be searched and viewed. If you’d like help immediately, feel free to search for a similar question, or submit your question or concern.


  • Profile Image

    Conditions being removed when changing condition number.

    Asked by hsuoscar on August 13, 2016 at 03:39 PM

    Conditional logics suddenly went missing

    I searched the forum and found that there were a few cases of "sudden conditional logics" missing.

    I used to the revision tools and found that there was an entry where 33 conditional logics were removed.  I am sure I did not do this and luckily I was able to get back my lost conditional logics by reverting to an earlier version.

    Still, this does not make me feel comfortable. I am worried that this might happen again.

    Thanks

    Page URL:
    https://form.jotform.me/62182252285454 

    missing conditions
  • Profile Image
    JotForm Support

    Answered by Welvin on August 13, 2016 at 05:56 PM

    When did you notice that you are missing the conditions, just today? Based on your account history, you've made some changes in the given form since August 6th. Can you please confirm if you've done that? 

    You may have edited the form into multiple windows and we don't recommend doing that. We have an autosave feature in the form builder. Once this is triggered, this will save the form and could override your changes on the other window, vice versa. 

    If you have lost the conditions without doing nothing then I can only think a glitch. Please confirm and we'll investigate further.

  • Profile Image

    Answered by hsuoscar on August 14, 2016 at 11:42 AM

    Yes, just today.  Conditional logics went missing (33 items) without doing anything.  I restored them from prevision revision as you could see probably.  This is the first time I see this kind of issue.

    I use only one editing windows.  It is possible that this is a glitch but I also saw in the forum that another user experienced this. Just letting you guys know.

     

  • Profile Image
    JotForm Support

    Answered by Mike on August 14, 2016 at 01:24 PM

    There might be a bug with removed conditions when you change a condition priority while viewing conditions related to a single field.

    In other words, it is safe to drag and drop conditions to change their priority in 'All Fields' mode.

    But it might be not safe in 'Field specific' mode. Do not drag conditions when you view the conditions related to a single field.

    This issue has been escalated to our developers now.

  • Profile Image

    Answered by grade4pagasa on August 15, 2016 at 12:44 AM

    I'm posting to follow this thread and receive updates, once available. 

  • Profile Image

    Answered by hsuoscar on August 15, 2016 at 10:14 PM

    @Mike, if fact you can only drag and drop conditions to change their priority in 'All Fields' mode but not in  'Field specific' mode.  My remedy now is that regardless of any modification, I would go to drop down menu and select appropriate item again.  

    I raised this question in https://www.jotform.com/answers/760863-how-do-you-order-conditional-logic as well.

     

  • Profile Image
    JotForm Support

    Answered by EltonCris on August 16, 2016 at 02:02 AM

    @hsuoscar

    Thanks for sharing your idea.

    The field specific view conditions were not meant to be draggable, however, due to browser compatibility issues, some of the users were able to drag them on Chrome browser - Windows OS. This is the reason why the other conditions are deleted when you change the orders of the conditions shown on field specific view. We were able to reproduce this problem and our developers are already informed about it. We have also added this thread into their bug list. Once we have updates about this, you will be informed here.

    Thanks!