Calculated Stripe total removed upon submission; Required Field error

  • Profile Image
    eileenjst
    Asked on August 22, 2016 at 04:55 PM

    I have a form that has a required 'checkbox' field, "choose a session", with 4 different sessions. Each session is set with a value of $20.

    In a 'hidden' 'Pre-cost' calculation field, I have setup so the cost is calculated for these.

    If all 4 sessions are selected, a hidden 'Discount' field is displayed, with a checkbox of $5 discount.

    The amount is then re-calculated in the second calculation field' Final Cost', which is the displayed as 'Final Cost'.

    The total Final Cost amount is passed to Stripe. The calculations produce the correct amount. The correct amount is passed to the stripe product display, however, when I click submit, the amount goes to '0' during the submission and I get an error page that says the required 'Choose a session' field is not selected. When I return from the link on the page to the form, all other data is still present but the 'Choose a Session' and the calculations are blank.

    I am in test mode at this time, but I've used test mode before without this problem.

  • Profile Image
    Kiran
    Answered on August 22, 2016 at 07:38 PM

    This thread seems to be a duplicate thread to https://www.jotform.com/answers/912776 which was already addressed by one of our colleagues. If you have any questions with this issue, we request you to follow-up on the other thread.

    If you are referring to something different, please let us know. We will be happy to help.