What is JotForm?
JotForm is a free online form builder which helps you create online forms without writing a single line of code. No sign-up required.

At JotForm, we want to make sure that you’re getting the online form builder help that you need. Our friendly customer support team is available 24/7.

We believe that if one user has a question, there could be more users who may have the same question. This is why many of our support forum threads are public and available to be searched and viewed. If you’d like help immediately, feel free to search for a similar question, or submit your question or concern.


  • Profile Image

    Docusign integration: Form displaying "Something's wrong" error after clicking on Sign button

    Asked by ubernederland on August 31, 2016 at 08:48 AM

    Hi,

    I tried the docusign widget on a simple jotform (https://form.jotformeu.com/62432715660352), but I keep getting an error.

    My docusign account is authenticated, but I don't know how to set it up further and the widget itself provides minimal guidance to be honest.

    Thank you,

    Thijs

    JotForm docusign jotformeu
  • Profile Image
    JotForm Support

    Answered by Chriistian on August 31, 2016 at 10:16 AM

    Hi,

    I was able to replicate the issue in your form and its clone.

    In my cloned form, here's what I did to resolve the issue.

    1. Remove the current DocuSign widget.

    2. Re-add the widget.

    3. Re-authenticate with your DocuSign account.

     

    Can you please do the same to your form and see if it works?

    Regards.

  • Profile Image

    Answered by ubernederland on August 31, 2016 at 10:49 AM

    Hi,

     

    I tried the same steps (https://form.jotformeu.com/62432715660352) with re-added widget and re-authenticated Docusign account, but still get an error message that something went wrong :(

  • Profile Image
    JotForm Support

    Answered by Chriistian on August 31, 2016 at 11:35 AM

    Hi,

    Here are the errors that I see in the console when I test your form.

     

    This might have something to do with the limits of your DocuSign account. I started receiving the same error from my form as soon as I reach the send limit for my DocuSign account.

    Can you please check the same with your account?

  • Profile Image

    Answered by ubernederland on September 01, 2016 at 03:05 PM

    I contacted Docusign with the error, this is their response:

     

    I see that in your test, you're sending your call to the www.docusign.net endpoint but the account specified appears to be on the na2.docusign.net server. Can you attempt to update the endpoint in your call and re-test? For your reference, the base URL is here: //{server}/restapi/{apiVersion}/{accountId}/

     

    Is this something that you guys can work with?

  • Profile Image
    JotForm Support

    Answered by Kiran on September 01, 2016 at 07:04 PM

    I have also tested the DocuSign integration and it seems that there is an issue with it. Let me forward the issue to our backend team to take a look. Once we have any update in this regard, you'll be posted here.

    Thank you! 

  • Profile Image

    Answered by ubernederland on September 05, 2016 at 04:59 AM

    Thank you, hopefully this can be resolved quickly, it would be very helpful!

  • Profile Image
    JotForm Support

    Answered by widgets on September 08, 2016 at 04:15 AM

    @ubernederland

    Hi thank you for reporting the DocuSign widget problem and we apologize for any inconvenience that this may have caused you. Today, we fixed the problem regarding base URIs on different regions/servers of DocuSign.

    We tried your test form and we're able to load the document with your custom color branding on it.

    Please do let us know if the problem still persist.

    Best Regards,
    Widget Team

  • Profile Image

    Answered by ubernederland on September 08, 2016 at 04:54 AM

    Hi,

    Thank you indeed my test form now works, thank you! 

    BUT

    When making a new doc and trying to authenticate the Docusign widget I get the following error:

     

    {"error":"Internal error: [400] Error connecting to the API (https:\/\/account.docusign.com\/oauth\/token?grant_type=refresh_token)","success":false,"duration":"0.256"}

    So the form that I already authenticated works, but authenticating the widget on a new form does not.

    Cheers, t

  • Profile Image
    JotForm Support

    Answered by widgets on September 08, 2016 at 05:06 AM

    @ubernederland

    Sorry about that, could you please try it again. Should be working fine now.

    Regards,
    Widget Team

  • Profile Image

    Answered by ubernederland on September 08, 2016 at 05:27 AM

    works!