My submit button changes to "Please wait..." but never runs or submits.

  • Profile Image
    sparktheatercompany
    Asked on September 06, 2016 at 10:11 PM

    We created our form for our theater auditions and copied the "Publish" and embed instructions for Wordpress. However, when somebody goes to our site, www.SparkTheaterCompany.com, and clicks the audition submission

    form and fills out our Jotform the "Submit" button changes to "Please wait..." but nothing runs and nothing

    submits. I have no idea what else to do with this. Please assist. Thank you!

    P.S. I use a Mac and I've tried on Firefox and Safari. My students have tried on Chrome and other browers on PCs.

  • Profile Image
    jonathan
    Answered on September 07, 2016 at 12:47 AM

    I checked your form https://www.jotform.us/form/62426381440148  on the website and I see the issue as well. I think it has to do with script conflict between the form scripts on those on the website.

    To fix, please try re-embed process using iframe embed code of the form. 

    Follow this guide to get the iframe embed code of the form.

    User guide: https://www.jotform.com/help/148-Getting-the-form-iFrame-code

    Make sure you remove first all the previous script codes of the embedded form before adding it back using its iframe embed code this time.

    Let us know if this did not resolve the issue.

    Thanks.