What is JotForm?
JotForm is a free online form builder which helps you create online forms without writing a single line of code. No sign-up required.

At JotForm, we want to make sure that you’re getting the online form builder help that you need. Our friendly customer support team is available 24/7.

We believe that if one user has a question, there could be more users who may have the same question. This is why many of our support forum threads are public and available to be searched and viewed. If you’d like help immediately, feel free to search for a similar question, or submit your question or concern.


  • Profile Image

    Not receiving all my email submissions

    Asked by markrojek1 on September 20, 2016 at 12:49 PM

    On the below form, if you chose any vehicle number other than 29-15, the submission will go through to Jotform, but not to the Admin Report email that I specified in the rules.

     

    Any thoughts?

    Page URL:
    https://form.jotform.com/60946484312155

    Submissions all email receiving conditions
  • Profile Image
    JotForm Support

    Answered by david on September 20, 2016 at 02:36 PM

    I checked our logs for the address that was supposed to receive the admin email and it looks like the emails are going through.  Check your spam/junkmail folder to ensure they are not being filtered there.  If they are not there, check your conditional statements to see if the appropriate condition is being met to send the email.

  • Profile Image

    Answered by markrojek1 on September 20, 2016 at 04:20 PM

    Yeah, I went through them.  If the Vehicle number is set to 29-15 everything functions fine.  It is only if you chose 16-06 for example that the form will only submit to Jotform and will not send the associated email to my Gmail address.

  • Profile Image
    JotForm Support

    Answered by david on September 20, 2016 at 05:58 PM

    I believe your are referring to the unit number field.  I checked the conditions associated with that field and there are no email conditions associated with that field.  I am not sure why setting that value differently would cause emails to work or not. 

    Set up a notification for the admin email that does not have a condition attached to see if the email triggers to that address when no conditions are involved.  If it does, then there is something in the conditions causing the emails not to trigger.

  • Profile Image

    Answered by markrojek1 on October 05, 2016 at 09:27 AM

    I'm still struggling and set up the extra email notifications based on how I was told from a previous post.

    https://www.jotform.com//?formID=60946484312155

    https://www.jotform.com//?formID=60646781099164

    When something is triggered to send a maintenance or ems email it seems like something goes wrong.  I always need the admin report sent, and if any of the conditions are met I need the other emails to go along with it.

     

    Any help would be greatly appreciated.

  • Profile Image
    JotForm Support

    Answered by John_Benson on October 05, 2016 at 11:17 AM

    Please give me more time to work on this issue. I will contact you once I have a solution. Thank you for your patience.

  • Profile Image
    JotForm Support

    Answered by John_Benson on October 05, 2016 at 12:16 PM

    Thank you for patiently waiting.

    I have checked your form and I can see that the 3 conditions are configured properly. These 3 email conditions is set to trigger the "Admin Report" notification if any of the conditions are met.

    Also, the email recipients of your notification are not in the bounce list. Are you not getting the "Admin Report" notification?

    I have cloned your form and I re-inserted the "Maintenance Deficiency" and "EMS Deficiency" conditions. I did a test submission and I was able to receive the "Admin Report" notification.

    Please try the steps below:

    1. Remove the "Maintenance Deficiency" notification in the Condition 2.
    2. Remove the "EMS Deficiency" notification in Condition 3.

    3. Save the form and the log out from JotForm.
    4. Restart your browser and then log back in to JotForm.
    5. Please add the "Maintenance Deficiency" notification in Condition 2.
    6. Please add the "EMS Deficiency" notification in Condition 3.

     

    Hope that helps. Let us know if the issue persist. Thank you.

  • Profile Image

    Answered by markrojek1 on November 16, 2016 at 09:48 PM

    Thanks, I finally pulled all of my email related conditional formatting out.  Saved it.  Logged Out. And then started over with inputting it and it works just as I wanted now.

  • Profile Image
    JotForm Support

    Answered by Chriistian on November 17, 2016 at 01:34 AM

    On the behalf of my colleague, you are welcome. We are glad you finally resolved regarding the issue.

    Please feel free to contact us again if you need further assistance.
    Regards.