What is JotForm?
JotForm is a free online form builder which helps you create online forms without writing a single line of code. No sign-up required.

At JotForm, we want to make sure that you’re getting the online form builder help that you need. Our friendly customer support team is available 24/7.

We believe that if one user has a question, there could be more users who may have the same question. This is why many of our support forum threads are public and available to be searched and viewed. If you’d like help immediately, feel free to search for a similar question, or submit your question or concern.


  • Profile Image

    Why am I getting an Incomplete Values error for not completing required fields when the fields are complete?

    Asked by salesoperations on September 22, 2016 at 07:14 PM

    I am getting an Incomplete Values error for completed fields.  The 2 fields it is saying are not completed are 'Your Position' and 'Description of Situation'.  How can I fix this?  

     

     

    Page URL:
    https://form.jotform.com/62216081069957

    Screenshot
    incomplete values Getting completing values
  • Profile Image
    JotForm Support

    Answered by Kevin_G on September 22, 2016 at 08:56 PM

    I have checked your form and I cannot replicate the issue, I was able to successfully submit your form without any problem, here is a screenshot of it: 

    Have you embedded your form in a webpage? 

    If so, please share us the link to the webpage, we will be glad to further test your form and find why it shows that message. 

    We will wait for your response. 

  • Profile Image

    Answered by salesoperations on September 23, 2016 at 11:03 AM

    We have not embedded this in a web page.  I just tried again this morning got the error again.  Same error message that I previously attached.  Is there anything you can suggest that I check so this doesn't happen? 

  • Profile Image
    JotForm Support

    Answered by Kevin_G on September 23, 2016 at 12:45 PM

    This seems a bit weird, I have just checked the form again and I can see it works fine on my end, please see the screen-cast below about when I tested your form: 

    I have cleared your forms cache, I will also suggest you to test your form into incognito mode so it will load with a fresh version instead of loading it from the cache saved version. 

    If the issue still persists, please set the fields as not required and submit your form, sometimes when this problem happens the fields with the errors do not have a value when they are submitted, if there is an issue then we should be able to replicate it on our end. 

    Please do let us know the result of your tests so we can also take a look again to your form.